Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158348 - traceback when attempting to act on a defined service
Summary: traceback when attempting to act on a defined service
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
: 159248 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 19:20 UTC by Corey Marthaler
Modified: 2009-04-16 20:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-07 19:18:37 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2005-05-20 19:20:22 UTC
Description of problem:
I believe this was caused when I attempted to disable a a defined service. I was
only able to produce this once.

Member morph-02.lab.msp.redhat.com disabling ...failed
rhpl.executil waitpid: No child processes
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/MgmtTab.py", line 230, in onTimer
    if self.model_builder.isClusterMember():
  File "/usr/share/system-config-cluster/ModelBuilder.py", line 402, in
isClusterMember
    return self.command_handler.isClusterMember()
  File "/usr/share/system-config-cluster/CommandHandler.py", line 55, in
isClusterMember
    out, err, res =
rhpl.executil.execWithCaptureErrorStatus("/sbin/magma_tool",args)
  File "/usr/lib/python2.3/site-packages/rhpl/executil.py", line 267, in
execWithCaptureErrorStatus
    if os.WIFEXITED(status) and (os.WEXITSTATUS(status) == 0):
UnboundLocalError: local variable 'status' referenced before assignment

Version-Release number of selected component (if applicable):
system-config-cluster-0.9.54-1.0.noarch.rpm

Comment 1 Corey Marthaler 2005-05-31 21:07:21 UTC
*** Bug 159248 has been marked as a duplicate of this bug. ***

Comment 2 Jim Parsons 2005-06-06 17:18:25 UTC
this error is in the RHPL library. I have fixed the RHPL error at cvs revision
number 1.11 for executil.py

Comment 3 Corey Marthaler 2005-09-02 20:50:31 UTC
Hit this again today after disabling an active IP service and then attempting to
start it on another machine. The service was running on link-11 and then I
disabled it and then dragged it to link-10.

[root@link-12 ~]# Member link-10 disabling 10.15.84.155...success
clustat
Member Status: Quorate, Group Member

  Member Name                              State      ID
  ------ ----                              -----      --
  link-11                                  Online     0x0000000000000003
  link-10                                  Online     0x0000000000000001
  link-12                                  Online     0x0000000000000002

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  10.15.84.155         (link-11                     ) disabled
[root@link-12 ~]# Member link-10 trying to enable 10.15.84.155...rhpl.executil
waitpid: No child processes
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/MgmtTab.py", line 230, in onTimer
    if self.model_builder.isClusterMember():
  File "/usr/share/system-config-cluster/ModelBuilder.py", line 402, in
isClusterMember
    return self.command_handler.isClusterMember()
  File "/usr/share/system-config-cluster/CommandHandler.py", line 61, in
isClusterMember
    out, err, res =
rhpl.executil.execWithCaptureErrorStatus("/sbin/magma_tool",args)
  File "/usr/lib/python2.3/site-packages/rhpl/executil.py", line 267, in
execWithCaptureErrorStatus
    if os.WIFEXITED(status) and (os.WEXITSTATUS(status) == 0):
UnboundLocalError: local variable 'status' referenced before assignment
success


The start up did however work:

[root@link-12 ~]# clustat
Member Status: Quorate, Group Member

  Member Name                              State      ID
  ------ ----                              -----      --
  link-11                                  Online     0x0000000000000003
  link-10                                  Online     0x0000000000000001
  link-12                                  Online     0x0000000000000002

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  10.15.84.155         link-10                        started


Comment 4 Stanko Kupcevic 2005-09-02 21:13:15 UTC
This traceback will never be seen again, as of version 1.0.13. For good.

Comment 5 Corey Marthaler 2005-09-07 19:18:37 UTC
fix verified in 1.0.15


Note You need to log in before you can comment on or make changes to this bug.