Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158346 - SDL-devel should Require: arts-devel or "sdl-config --libs" should fixed
Summary: SDL-devel should Require: arts-devel or "sdl-config --libs" should fixed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-05-20 19:04 UTC by Thorsten Leemhuis
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.2.8-3.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-26 22:07:31 UTC


Attachments (Terms of Use)

Description Thorsten Leemhuis 2005-05-20 19:04:04 UTC
Description of problem:
Rebuild apps like smjpeg, SDL_sound or mpeg3dec fails on FC4T3 because they
can't find "/usr/lib64/libartsc.so". Okay, BR arts-devel is missing. Why? Did
not happen with FC4T2...

After some investigations I saw that SDL-1.2.8-3.1 from FC4T3 does have a
require on libartsc.so.0()(64bit), but SDL-1.2.7-8 from FC4T2 did not. Okay,
seems SDL uses arts now, so probably sdl-config --libs should show that also. It
does not:

$ sdl-config --libs
-L/usr/lib64 -lSDL -lpthread

But it seems it is needed. See also:
$ grep arts /usr/lib64/libSDL.la
dependency_libs=' -lasound -lm -L/usr/lib64 /usr/lib64/libartsc.la
-L/usr/lib64/qt-3.3/lib -L/usr/X11R6/lib64 -lgmodule-2.0 -ldl -lgthread-2.0
-lglib-2.0 -lX11 -lXext -lpthread'

So sdl-config should be fixed and/or SDL-devel should "Require: arts-devel"

Version-Release number of selected component (if applicable):
SDL-1.2.8-3.1

How reproducible:
Always

Additional info:
Bug 140301 (sdl-config --libs outputs insufficient parameters) is related and
probably still valid
Bug 145974 (remove %_libdir/lib*.la files) probably also -- but that's to late
for FC4 afaics...

Comment 1 Bill Nottingham 2005-05-26 20:37:00 UTC
Actually, something more serious is wrong here. SDL requires arts... only on x86_64.

Why would it only pick it up there?


Comment 2 Bill Nottingham 2005-05-26 22:07:31 UTC
Fixed in 1.2.8-3.2.


Note You need to log in before you can comment on or make changes to this bug.