Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158329 - System Hanges at boot time
Summary: System Hanges at boot time
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils
Version: 3.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Geoff Gustafson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 16:04 UTC by V S Rao
Modified: 2007-11-30 22:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-05 14:57:14 UTC


Attachments (Terms of Use)

Description V S Rao 2005-05-20 16:04:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
After updating the kernel-utils rpm to version 2.4-8.37.12 my Compaq Proliant ML570 server hanges at the boot message

Apllying Intel IA32 Microcode updates

Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.37.12

How reproducible:
Didn't try

Steps to Reproduce:
1.upgrage to the above version
2.Reboot
3.
  

Actual Results:  System Hanges

Expected Results:  It should have given OK after the above message and continued with the booting procedure.

Additional info:

Problem resolved by rolling back to kernel-utils version 2.4-8.37.7

Comment 1 Dave Jones 2005-05-21 07:32:14 UTC
can you paste the output of /proc/cpuinfo from that box please ?


Comment 2 V S Rao 2005-05-21 08:19:34 UTC
This is a HP Proliant ML 570 machine with 4 CPU & 8 GB RAM. The output of
/proc/cpuinfo is pasted below:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3984.58

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3997.69

processor       : 2
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 1
siblings        : 2
runqueue        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3997.69

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 1
siblings        : 2
runqueue        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3997.69

processor       : 4
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 2
siblings        : 2
runqueue        : 4
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3997.69

processor       : 5
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 2
siblings        : 2
runqueue        : 4
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4010.80

processor       : 6
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 3
siblings        : 2
runqueue        : 6
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3997.69

processor       : 7
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 2.00GHz
stepping        : 2
cpu MHz         : 1999.967
cache size      : 512 KB
physical id     : 3
siblings        : 2
runqueue        : 6
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3997.69

Comment 3 Gordon Jin 2005-05-28 01:49:22 UTC
vsrao,
with 2.4-8.37.7, could you do:
1) uname -a
2) /etc/init.d/microcode_ctl start
Please let me know the result. Thanks.


Comment 4 V S Rao 2005-05-28 05:33:58 UTC
This is a production machine. Just yesterday upgraded it from AS 3 to AS 4. Now
the kernel is 2.6. Can't roll back and give the result.

I only have one ML570. I could install AS 3 on another machine (Single CPU,
Pentium 4 Processor) and then try to experiment and give the result. But would
it help? If so pls let me know. 

Vsrao

Comment 5 Gordon Jin 2005-05-29 03:14:25 UTC
Thanks, Vsrao. You could do that if convenient.

I've installed RHEL3-U5 (with kernel-utils-2.4-8.37.12 shipped) on a Xeon
machine, and didn't reproduce your problem.

Could you confirm:
1) By "uname -a": Is it i686, not x86-64?
2) The OS is pure AS 3, without any update like U4 or U5?

Comment 6 Jason T Hardy 2005-06-09 22:25:27 UTC
I've encountered the same problem on an IBM eSeries xServer 360 with the same
processors (4-way 32-bit Xeon with HT enabled). The machine booted fine when I
installed from the U4 cd's. After upgrading to U5 from RHN the problem was
reproduced.

Upon booting the system hangs at "Applying Intel IA32 microcode update." I
disabled the microcode script and was able to produce the following output for
your reference:

kernel-utils-2.4-8.37.12

Linux sigma.uta.edu 2.4.21-32.0.1.ELsmp #1 SMP Tue May 17 17:52:23 EDT 2005 i686
i686 i386 GNU/Linux

Issuing the microcode update manually reproduces the "hung" state.

bash-2.05b# /sbin/microcode_ctl -u
/sbin/microcode_ctl: writing microcode (length: 208896)

Here's the /proc/cpuinfo for your reference

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

processor       : 2
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 1
siblings        : 2
runqueue        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 1
siblings        : 2
runqueue        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

processor       : 4
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 2
siblings        : 2
runqueue        : 4
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

processor       : 5
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 2
siblings        : 2
runqueue        : 4
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

processor       : 6
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 3
siblings        : 2
runqueue        : 6
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

processor       : 7
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) MP CPU 1.90GHz
stepping        : 2
cpu MHz         : 1900.443
cache size      : 512 KB
physical id     : 3
siblings        : 2
runqueue        : 6
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3787.98

Comment 7 Gordon Jin 2005-06-18 02:18:14 UTC
Jason, could you get the latest BIOS from vendor(IBM) to see if this problem 
goes away?

Comment 8 Jason T Hardy 2005-06-20 15:15:46 UTC
I've upgraded the POST/BIOS to 1.14 using IBM's UpdateXpress 4.0.1. This appears
to solve my problem. The microcode utility has nothing to do:

microcode: CPU0 already at revision 0x5 (current=0x5)
microcode: CPU1 already at revision 0x5 (current=0x5)
microcode: CPU2 already at revision 0x5 (current=0x5)
microcode: CPU3 already at revision 0x5 (current=0x5)
microcode: CPU4 already at revision 0x5 (current=0x5)
microcode: CPU5 already at revision 0x5 (current=0x5)
microcode: CPU6 already at revision 0x5 (current=0x5)
microcode: CPU7 already at revision 0x5 (current=0x5)

Comment 15 Gordon Jin 2005-08-11 00:44:37 UTC
A workaround microcode update data is posted at Intel issue tracker 76581 for 
EL3-U6
https://enterprise.redhat.com/issue-tracker/?
module=issues&action=view&tid=76581

It removes the microcode for stepping f22 so this system hang will not happen 
on f22 if EL3-U6 includes that workaround microcode.

Comment 18 Peter Martuccelli 2005-10-18 18:45:40 UTC
This issue will be resolved in RHEL3 U7.

Comment 21 Peter Martuccelli 2006-01-05 14:57:14 UTC

*** This bug has been marked as a duplicate of 165987 ***


Note You need to log in before you can comment on or make changes to this bug.