Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158326 - kernel panic on shutdown
Summary: kernel panic on shutdown
Keywords:
Status: CLOSED DUPLICATE of bug 155472
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 15:22 UTC by Joseph Shraibman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-21 07:29:34 UTC


Attachments (Terms of Use)
first screen shot (from digital camera) (deleted)
2005-05-20 15:23 UTC, Joseph Shraibman
no flags Details
second screen shot (deleted)
2005-05-20 15:24 UTC, Joseph Shraibman
no flags Details

Description Joseph Shraibman 2005-05-20 15:22:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
This is the 32 bit kernel running on an Athlon 64.

I have a usb hard drive enclosure.  When I plug it in, and then unplug it, even if I never mounted any file system, I get a kernel panic on shutdown.

In drivers/block/cfq-iosched.c line 1065

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. I'm not sure if this happens every time, but I'm not planning on finding out
2.
3.
  

Additional info:

Bus 001 Device 003: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x05e3 Genesys Logic, Inc.
  idProduct          0x0702 USB 2.0 IDE Adapter
  bcdDevice            0.02
  iManufacturer           0 
  iProduct                1 USB TO IDE
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xc0
      Self Powered
    MaxPower               96mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk (Zip)
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0200  bytes 512 once
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0200  bytes 512 once
        bInterval               1
  Language IDs: (length=4)
     0409 English(US)

Comment 1 Joseph Shraibman 2005-05-20 15:23:52 UTC
Created attachment 114630 [details]
first screen shot (from digital camera)

Comment 2 Joseph Shraibman 2005-05-20 15:24:26 UTC
Created attachment 114632 [details]
second screen shot

Comment 3 Dave Jones 2005-05-21 07:29:34 UTC

*** This bug has been marked as a duplicate of 155472 ***


Note You need to log in before you can comment on or make changes to this bug.