Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158302 - Embedded browser not available
Summary: Embedded browser not available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 14:08 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-25 13:10:28 UTC


Attachments (Terms of Use)

Description Robin Green 2005-05-20 14:08:03 UTC
Description of problem:
MOZILLA_FIVE_HOME is not set, so the embedded browser widget fails to start

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.18

How reproducible:
Always

Steps to Reproduce:
1. In eclipse, create a file called "test.html"
  
Actual results:
Eclipse says: "Embedded browser not available" and offers to "open file using
the system editor". The detailed error message is:

org.eclipse.swt.SWTError: No more handles [Unknown mozilla path
(MOZILLA_FIVE_HOME not set)]

Expected results:
Should use mozilla or firefox for the embedded browser widget

Additional info:
I am currently running eclipse on Sun JDK 1.5, but I don't think that should
make a difference, because MOZILLA_FIVE_HOME would not be set whichever VM you use.

Suggested fix: Add the following to /usr/bin/eclipse:

if [ -z "$MOZILLA_FIVE_HOME" ]; then
  XPCOM=$(ls -t /usr/lib/{mozilla,firefox}-*/libxpcom.so|head -n1)
  export MOZILLA_FIVE_HOME=$(dirname $XPCOM)
fi
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$MOZILLA_FIVE_HOME

Comment 1 Andrew Overholt 2005-05-20 15:06:42 UTC
I've been meaning to fix this - thanks for doing it!  I'll include it in our
next build.

Comment 2 Ben Konrath 2005-05-25 05:15:21 UTC
This has been fixed in the M7 packages. Can you test to make sure this works for
you and close this bug if it does? Thanks for the patch.

Comment 3 Robin Green 2005-05-25 13:10:28 UTC
Yeah, it works for me with the eclipse 3.1M7 rpms.


Note You need to log in before you can comment on or make changes to this bug.