Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158291 - 8139too network driver ignoring traffic.
Summary: 8139too network driver ignoring traffic.
Keywords:
Status: CLOSED DUPLICATE of bug 156261
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 10:44 UTC by Eugene Roux
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-25 15:04:41 UTC


Attachments (Terms of Use)

Description Eugene Roux 2005-05-20 10:44:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.20

Description of problem:
I've been experiencing intermittent problems with the 8139too on Rawhide kernels.

The network worked fine with Test2, but broke soon after on kernel-2.6.11-1.1286_FC4 and kernel-2.6.11-1.1287_FC4

On kernel-2.6.11-1.1290_FC4 it appeared fine again, but since I've tried kernel-2.6.11-1.1312_FC4+ it has been broken cosistently.

Version-Release number of selected component (if applicable):
Works on kernel-2.6.11-1.1290_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot system wit affected kernel
2. Acquire address with DHCP (which sometimes works)
3. Try to SSH out...
  

Actual Results:  The SSH link hangs.

Snooping the interface shows some other traffic on the link, but I dont see any outgoing traffic from my box.

Expected Results:  SSH link should establish, data should flow to and fro my box.

Additional info:

MII claims that the link is up at 100 full duplex, autonegotiated.

Comment 1 John W. Linville 2005-05-24 20:00:49 UTC
In bug 156261, another user found his 8139 problems were alleviated by adding 
"tpm_atmel" and "tpm_nsc" in /etc/hotplug/blacklist.  Would you mind giving 
that a try to see if this has any effect on the problem you are experiencing? 
 
Please report the results here.  Thanks! 

Comment 2 Eugene Roux 2005-05-25 09:58:24 UTC
I've updated to 2.6.11-1.1341_FC4.

It displayed the same symptoms until I added "tpm_atmel" and "tpm_nsc" to the
hotplug blacklist file.

To be honest, only "tpm_atmel" seemed to get itself loaded, so it might have
been sufficient to only add it to the list.

With those modules blacklisted, networking worls like a charm (again).

Comment 3 John W. Linville 2005-05-25 12:59:16 UTC
Interesting...would mind removing those modules from the blacklist, then 
trying the kernels here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
They include a patch from the tpm driver maintainer that she believe might be 
helpful.  Please post the results of using those kernels here.  Thanks! 

Comment 4 Eugene Roux 2005-05-25 14:51:26 UTC
Yep...

Installed kernel-2.6.11-1.1353.2.1_FC4.jwltest.3.i686.rpm and hashed out
"tpm_atmel" and "tpm_nsc" in /etc/hotplug/blacklist.

Seems to work just fine so far...

Comment 5 John W. Linville 2005-05-25 14:56:24 UTC
Excellent!  Thanks for the quick response! 

Comment 6 John W. Linville 2005-05-25 15:04:41 UTC
Closing as DUPLICATE of 156261...(presuming that issue is fixed as well...) 

*** This bug has been marked as a duplicate of 156261 ***


Note You need to log in before you can comment on or make changes to this bug.