Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158290 - Rpm pre and post scripts fail en-masse
Summary: Rpm pre and post scripts fail en-masse
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 10:35 UTC by Aidan Delaney
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 08:35:03 UTC


Attachments (Terms of Use)

Description Aidan Delaney 2005-05-20 10:35:07 UTC
Description of problem:
I believe that this is a well known problem associated with SELinux, however I
can't find a report in bugzilla.

Yum update and install leaves system in strange state because most pre and/or
post scripts for RPMs fail.  By strange state I mean that (for example): If I
update eclipse I am left with rpm -q telling me that I have two eclipse
installed.  I've also included gnome-media below to show that the problem is
generic rather than just with the eclipse packages.

[root@mowa423-lxajd9 ~]# rpm -qa | grep eclipse
eclipse-ecj-3.1.0_fc-0.M6.18
eclipse-ecj-3.1.0_fc-0.M6.19
eclipse-platform-3.1.0_fc-0.M6.18
eclipse-platform-3.1.0_fc-0.M6.19
eclipse-ecj-3.1.0_fc-0.M6.16
eclipse-platform-3.1.0_fc-0.M6.16
[root@mowa423-lxajd9 ~]# rpm -qa | grep gnome-media
gnome-media-2.10.2-1
gnome-media-2.10.2-2


Version-Release number of selected component (if applicable):
Fedora Core Rawhide

How reproducible:
Always

Steps to Reproduce:
1. yum update
  
Actual results:
snippet from the middle of one update

  Updating  : device-mapper                ####################### [38/98]
error: %post(device-mapper-1.01.02-1.0.i386) scriptlet failed, exit status 255
  Updating  : totem                        ####################### [39/98]
error: %post(totem-1.0.2-1.i386) scriptlet failed, exit status 255
  Updating  : system-config-securitylevel  ####################### [40/98]
error: %post(system-config-securitylevel-1.5.8-1.i386) scriptlet failed, exit
status 255
  Updating  : hwbrowser                    ####################### [41/98]
error: %pre(kernel-2.6.11-1.1319_FC4.i686) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping kernel-2.6.11-1.1319_FC4
  Updating  : beecrypt-python              ####################### [43/98]
  Updating  : evolution-data-server-devel  ####################### [44/98]
error: %pre(bind-9.3.1-4.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping bind-9.3.1-4
error: %pre(kernel-smp-2.6.11-1.1319_FC4.i686) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping kernel-smp-2.6.11-1.1319_FC4


Expected results:
The packages should install smoothly

Additional info:
I originally had SELinux enabled but turned it off.  I re-enabled it a few days
ago.  I've tried an "rpm -vvvvvi packagename" but that dosn't tell me why the
pre and post scripts are failing.

Comment 1 Jeremy Katz 2005-05-23 14:52:52 UTC
How did you turn off selinux?  rpm will look in /etc/selinux/config to see if
it's enabled or not.

Comment 2 Paul Nasrat 2005-05-23 15:04:35 UTC
Did you relable the filesystem after re-enabling? Are there any avc messages?

Comment 3 Aidan Delaney 2005-05-23 15:24:21 UTC
To turn off selinux I chaned the string in /etc/selinux/config to "disabled". 
To re-enable it I used the GUI.  I'm not sure if I re-labeled the file system
after restart.  I'll do that now.

Comment 4 Aidan Delaney 2005-05-24 08:35:03 UTC
The fix is to relable the file system.

I've changed this to NOTABUG as there's no THESUBMITTERISANASS option :)


Note You need to log in before you can comment on or make changes to this bug.