Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158278 - vnc not an option when using pxeboot to create pxe boot files
Summary: vnc not an option when using pxeboot to create pxe boot files
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-netboot
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 09:02 UTC by Chris Jenkins
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-20 14:54:02 UTC


Attachments (Terms of Use)

Description Chris Jenkins 2005-05-20 09:02:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
We use /usr/sbin/pxeboot to create pxe boot files. A feature of pxe boot files is that you can specify a vnc server to display the graphical installation, meaning you can remotely view anaconda installing the OS.


Version-Release number of selected component (if applicable):
redhat-config-netboot-0.1.5-1

How reproducible:
Always

Steps to Reproduce:
1. pxeboot -a -O RedHat-4WS-x86_64 -K nfs:installserver:/var/install/kickstart/robinhood-kickstart vnc robinhood
  

Actual Results:  default RedHat-4WS-x86_64

label RedHat-4WS-x86_64
    kernel RedHat-4WS-x86_64/vmlinuz
    append initrd=RedHat-4WS-x86_64/initrd.img  ks=nfs:installserver:/var/install/kickstart/robinhood-kickstart ramdisk_size=10000

Expected Results:  default RedHat-4WS-x86_64

label RedHat-4WS-x86_64
    kernel RedHat-4WS-x86_64/vmlinuz
    append initrd=RedHat-4WS-x86_64/initrd.img  ks=nfs:installserver:/var/install/kickstart/robinhood-kickstart vnc ramdisk_size=10000

Additional info:

vnc should be an option in pxeboot because it is possible to specify it manually in a pxe boot file. Looking at pxeboot, which is a python script, it looks fairly straightforward to add this as an option, perhaps a -vnc switch.

Currently, we are getting around the problem using the following method:

pxeboot -a -O RedHat-4WS-x86_64 -K "nfs:installserver:/var/install/kickstart/robinhood-kickstart vnc" robinhood

This works because the argument to -K isn't parsed so is just echoed into the output file.

From a business perspective, we are an organisation who automate everything possible because of the amount of machines we administer. We think that the sort of organisation which uses pxeboot to generate files are the ones most likely to need vnc enabled at install time.

Comment 1 Suzanne Hillman 2005-05-20 14:54:02 UTC
In order to file a RHEL feature request, please either contact Red Hat's
Technical Support line at 888-REDHAT-1 or file a web ticket at
http://www.redhat.com/apps/support/.  Bugzilla is not an official support
channel, has no response guarantees, and may not route your request to the
correct area to assist you.  Using the official support channels above will
guarantee that your issue is handled appropriately and routed to the
individual or group which can best assist you with this issue and will also
allow Red Hat to track the issue, ensuring that any applicable feature
addition is included in all releases and is not dropped from a future update
or major release.


Note You need to log in before you can comment on or make changes to this bug.