Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158276 - Problem with NFS
Summary: Problem with NFS
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils
Version: 3.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 08:53 UTC by sumanpatra
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:01:52 UTC


Attachments (Terms of Use)

Description sumanpatra 2005-05-20 08:53:42 UTC
Description of problem:
nfsd: bad address count in freeclient! (Received in dmesg)
rpc.mountd: getfh failed: Operation not permitted (Received 
in /var/log/messages)

[root@becnfs1 root]# more /etc/exports
#/oracle   *(rw,anonuid=1030,anongid=120)
#/icp_mktplace_dev  *(rw,anonuid=0,anongid=0)
/oracle *(rw,anonuid=0,anongid=0,no_auth_nlm)
/icp_mktplace_dev *(rw,no_root_squash)
/icp_mktplace_qa *(rw,no_root_squash)
/oracle9i *(rw,no_root_squash)
/ora_adm *(rw,no_root_squash,no_auth_nlm)
/ora_data *(rw,no_root_squash,no_auth_nlm)
/ora_req_data *(rw,no_root_squash)
/allbackup *(rw,no_root_squash)
[root@becnfs1 root]# exportfs
/icp_mktplace_dev
                <world>
/icp_mktplace_qa
                <world>
/ora_req_data   <world>
/allbackup      <world>
/oracle9i       <world>
/ora_data       <world>
/ora_adm        <world>
/oracle         <world>
[root@becnfs1 root]# showmount -e becnfs1
Export list for becnfs1:
/oracle           *
/ora_adm          *
/ora_data         *
/oracle9i         *
/allbackup        *
/ora_req_data     *
/icp_mktplace_dev *
[root@becnfs1 root]#

If you check above you will see showmount command is not reporting 
about /icp_mktplace_qa, although it is nfs mounted in so many system.Now I am 
trying to mount it in a system, where it was mounted previously. Now I am 
getting error "nfs mount: becnfs1:/icp_mktpace_qa: Permission denied". By the 
same time I am able to mount the same in other system.

This is happened very frequently and giving error in df -k output : nfsstale 
erorr.

Due to this problem we lost so many database (Corrupted) and we have to 
recretae it (In production environment)

We are mounting this to HPUX, SUN SOLARIS.

We are not able to nfsmount to IBM-AIX from LINUX also, that is another issue 
we are faing with linux (Although we are able to nfs mount to IBMAIX from HPUX, 
SUN SOLARIS).

Please help me.

Thanks & regards,
Suman

Here is the require information.


Version-Release number of selected component (if applicable):
[root@becnfs1 root]# uname -r
2.4.21-4.ELsmp
[root@becnfs1 root]# rpm -qa | grep nfs
redhat-config-nfs-1.0.13-1
nfs-utils-1.0.5-3
[root@becnfs1 root]#


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Steve Dickson 2005-05-20 11:37:21 UTC
Try exporting with the no_subtree_check options, to see if that helps

Comment 2 sumanpatra 2005-05-20 11:53:33 UTC
Sure I will check that option. But at present I can't restart nfs service as  
so many database is nfs mounted in different server.
But still I am able to mount/unmount it in other server. Even I have tried with 
rebooting the concerned solaris server. But no luck.
Colud you please give me the root cause behind this kind of abnormal behaviour.
Today it is happened with one server, tomorrow it will happen to some other 
server. In last three month we have faced same problem with two different 
server.

Comment 3 Steve Dickson 2005-05-20 13:02:57 UTC
Are you doing something that is causing exports to be
added or subtracted? It appears the reason your are
getting the  rpc.mountd: and  nfsd:  messages is, there are
inconstancies in the exports list. This could also explain
the nfs mount: Permission denied error and nfsstale error .

Comment 4 sumanpatra 2005-05-20 13:22:39 UTC
No, This file was modifed long back. Nobody touched that file.

Comment 5 Steve Dickson 2005-05-23 10:41:24 UTC
Ok... would it be possible to get an bzip2 binary tethereal
trace (i.e. tethereal -w /tmp/data.pcap) of these failure (especially
the "nfsmount to IBM-AIX from LINUX" ).

Here is another shot in the dark.... I seem to remember that
exporting with insecure and insecure_locks helped with
HPUX mounts... Because I believe (at one time) HP used
non-reserver ports to do mounting which is something LINUX
servers rejects

Comment 6 RHEL Product and Program Management 2007-10-19 19:01:52 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.