Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158265 - tcsh -e bails out at the beginning of /etc/csh.cshrc
Summary: tcsh -e bails out at the beginning of /etc/csh.cshrc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setup
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-20 02:11 UTC by Richard Walker
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version: 2.5.44-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-20 04:00:27 UTC


Attachments (Terms of Use)
patch for this (deleted)
2005-05-20 03:59 UTC, Bill Nottingham
no flags Details | Diff

Description Richard Walker 2005-05-20 02:11:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/103u (KHTML, like Gecko) Safari/100

Description of problem:
running "tcsh -eX" for me produces this:
id -gn
id -un
id -u
[ cntrctrs = rjwalker -a 1009 -gt 99 ]
Then tcsh bails out - I do not get a new shell.


Version-Release number of selected component (if applicable):
setup-2.5.36-1

How reproducible:
Always

Steps to Reproduce:
1. Log in with a user where the user id and group id are different
2. Run tcsh -eX
  

Actual Results:  You don't get a new shell.


Expected Results:  You should get a new shell!

Additional info:

The problem is the very beginning of /etc/csh.cshrc.  It shouldn't use exit
codes in this way.  (And neither should any other script in /etc/profile.d.)

This sort of problem was identified previously in bug 139988.

Comment 1 Bill Nottingham 2005-05-20 03:59:40 UTC
Created attachment 114610 [details]
patch for this

Here's what will be in 2.5.44-1.

Comment 2 Bill Nottingham 2005-05-20 04:00:27 UTC
(Note that patch is relative to 2.5.43.)


Note You need to log in before you can comment on or make changes to this bug.