Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158258 - Installer hangs upon booting first ISO disk
Summary: Installer hangs upon booting first ISO disk
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 158264 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 23:12 UTC by Jeffrey D. Yuille
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 01:05:27 UTC


Attachments (Terms of Use)

Description Jeffrey D. Yuille 2005-05-19 23:12:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
Upon installation of the first ISO disk of FC4T3 on a Dell Inspiron 4000 Laptop, Anaconda fails to bring up the installation screen, which would allow me to choose my mode of installation.  Instead, the only thing I see is a checkerboard screen with funny characters.  When I attempt to reinsert the first ISO disk, I will also see a text-based mode of choices. However, I cannot make any choices because the keyboard is frozen and doesn't allow to me to make any entries. I checked the quality of the disks themselves and was able to perform the installation from them on an IBM ThinkPad T-30 Laptop and a Dell Dimension XPS T600r. Incidentally, I am using the Dell Inspiron at this moment by reinstalling FC3 on it, which works fine.  The only conclusion that I can make from this is that the Anaconda installer will not install on a Dell Inspiron.  This was the case when I burned disks for Fedora Core 4, test 1,2 and now 3.  Will this issue be corrected in the final release?   

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Comment 1 Jeremy Katz 2005-05-20 00:01:32 UTC
Does booting with 'linux nofb' help?

Comment 2 Jeffrey D. Yuille 2005-05-20 00:17:53 UTC
Well, for one, I cannot even enter any commands because either the first thing I
see after loading the disk is a checkerboard-like apprearance with funny
characters or text with some options that I cannot choose because the keyboard
seems to be locked and thus not allowing me to any choices. 

Comment 3 Chris Kapsalis 2005-05-21 18:44:36 UTC
Similar problem for Dell notebook CPi-R series.  This occurs for all FC4T1, 
FC4T2 and FC4T3 boot.iso, FC4T3 disc1, or rescue discs.

This system had no problems installing either FC2 or FC3 (via cd-rom or network
).

Symptom: CD-ROM loads to text install screen, the first part of screen shifts up 
and the system hangs.  Unable to get any key presses to do anything. 

All that is displayed is:

- To install or upgrade in graphical mode, press the <ENTER> key.
- To install or upgrade in text, type: linux text <ENTER>
- Use the function keys listed below for more information.

[F1-Main] [F2-Options] [F3-General] [F4-Kernel] [F5-Rescue]


Comment 4 Jeffrey D. Yuille 2005-05-22 03:50:36 UTC
(In reply to comment #3)
> Similar problem for Dell notebook CPi-R series.  This occurs for all FC4T1, 
> FC4T2 and FC4T3 boot.iso, FC4T3 disc1, or rescue discs.
> 
> This system had no problems installing either FC2 or FC3 (via cd-rom or network
> ).
> 
> Symptom: CD-ROM loads to text install screen, the first part of screen shifts up 
> and the system hangs.  Unable to get any key presses to do anything. 
> 
> All that is displayed is:
> 
> - To install or upgrade in graphical mode, press the <ENTER> key.
> - To install or upgrade in text, type: linux text <ENTER>
> - Use the function keys listed below for more information.
> 
> [F1-Main] [F2-Options] [F3-General] [F4-Kernel] [F5-Rescue]
> 

Yes, this is the same exact problem that I am having with a Dell Inspiron 4000!

Comment 5 Jeremy Katz 2005-05-23 15:20:59 UTC
Can you try booting the boot.iso from the devel tree?  I think this is a bug
which is fixed in syslinux 3.08 (which we've since included)

Comment 6 Jeremy Katz 2005-05-23 21:40:03 UTC
*** Bug 158264 has been marked as a duplicate of this bug. ***

Comment 7 Jeffrey D. Yuille 2005-05-24 00:19:57 UTC
I was able to go to the development tree to download the boot.iso image.  I
burned it to a cd-r disk and it was able to boot the laptop.  However, when it
asked for the cdrom disk, I put it in but it was not able to find it.  Instead,
an error message stated "No Fedora Core CD was found which matches your boot
media.  Please insert the Fedora Core CD and press Ok to retry".  Do they mean
the original CD's that I burned to initially instal the laptop? If so, why is
the boot media not able to find the FC4T3 disk?  

Comment 8 Jeremy Katz 2005-05-24 01:05:27 UTC
The boot cd has to match the tree you're installing from, so you'd have to do an
install of the rawhide tree with that.  But that verifies that things should be
fixed for FC4 final.

Comment 9 Jeffrey D. Yuille 2005-05-24 01:36:47 UTC
Since I was able to get the boot.iso from the development tree, where do I find
the corresponding ISO's?  Forgive me, but I don't know what Rawhide is. 

Comment 10 Chris Kapsalis 2005-05-25 00:01:40 UTC
Just wanted to confirm that the boot.iso from the development tree worked OK.

I'm looking forward to FC4 final.  Thanks for your help!


Note You need to log in before you can comment on or make changes to this bug.