Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158257 - passwords are logged in rhn_server_xmlrpc.log
Summary: passwords are logged in rhn_server_xmlrpc.log
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 370
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Wregglesworth
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 23:09 UTC by Jack Neely
Modified: 2007-07-31 15:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 21:38:54 UTC


Attachments (Terms of Use)

Description Jack Neely 2005-05-19 23:09:36 UTC
Description of problem:

Please, please, please don't log passwords in rhn_server_xmlrpc.log.  Everytime
reserve_user() is logged, the password is right there.  Please don't log the
passwords!

Comment 1 John Wregglesworth 2005-06-20 21:38:54 UTC

*** This bug has been marked as a duplicate of 151157 ***

Comment 2 Debbie McGrath 2005-06-21 15:33:06 UTC
Moving to rhn400-must, since the duplicate is there.

Comment 3 Jack Neely 2006-08-21 18:25:15 UTC
I don't have permission for bug #151157.  Has this been fixed in later versions?
 I still see this issue in 370.


Note You need to log in before you can comment on or make changes to this bug.