Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158246 - Cannot kick using x86_64 WS3 U2
Summary: Cannot kick using x86_64 WS3 U2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: unspecified
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jason Connor
QA Contact: Max Spevack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 20:28 UTC by Matthew Davis
Modified: 2014-03-31 01:38 UTC (History)
3 users (show)

Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-01 02:48:49 UTC


Attachments (Terms of Use)

Description Matthew Davis 2005-05-19 20:28:10 UTC
Description of problem:

We created a kickstart profile using the Red Hat Enterprise Linux WS (v. 3 for
AMD64/Intel EM64T) (ks-rhel-x86_64-ws-3) distribution.  This is, in essence, U2.
 However we cannot kickstart using that distro.


Version-Release number of selected component (if applicable):

3.7.1

How reproducible:

Always.

Steps to Reproduce:
1. Create a kickstart profile using ks-rhel-x86_64-ws-3
2. Kickstart a machine using that profile
  
Actual results:

ERROR: Could not find the needed RHN provisioning packages given this system's
current base channel and desired target channel.

Expected results:

Successful kickstart

Comment 3 Robin Norwood 2005-06-13 17:13:15 UTC
I think this is jconnor's - Looking at the data in webdev, it looks like the
tree in question (label: ks-rhel-x86_64-ws-3) has a 'boot_image' of
'ks-rhel-x86_64-ws-3'.

We don't have such a package, but we do have:

auto-kickstart-ks-rhel-x86_64-ws-3-u2
auto-kickstart-ks-rhel-x86_64-ws-3-u3
auto-kickstart-ks-rhel-x86_64-ws-3-u4

So I guess the 'plain' distrubution needs to go away and be replaced by one for u2.

Same goes for AS and ES, of course.

Comment 4 Jason Connor 2005-06-13 21:48:54 UTC
The missing trees have been added to WEBQA

Comment 5 Jason Connor 2005-06-17 15:04:58 UTC
test plan:
Kick an x86_64 box to rhel 3 u 2 (as, es, ws)

Comment 6 Beth Nackashi 2005-08-04 18:32:40 UTC
rhel 3 U2 kickstarts are failing

for some reason, anaconda can't find the scsi hard drive

this is the error:
VFS:  Can't find ext2 filesystem on dev loop(7,0)

I was testing on mspevack64.rdu.redhat.com.

Comment 7 Jason Connor 2005-08-04 18:45:22 UTC
Beth, you'll need to open a bug against anaconda. This bug is currently aligned
to RHN/kickstart.

Comment 8 Jason Connor 2005-08-04 18:47:29 UTC
I'm setting the bug into NEEDINFO until we can resume testing after fixing anaconda.

Comment 9 Beth Nackashi 2005-08-04 19:42:42 UTC
See 165162.

Comment 10 Mihai Ibanescu 2005-08-05 20:11:22 UTC
In that case, we're back to comment #4 - moving to ON_QA

Comment 11 Max Spevack 2005-08-08 15:51:33 UTC
in process of testing now.

Comment 12 Max Spevack 2005-08-08 16:00:21 UTC
x86_64 rhel-3-u2-ws kickstart works out of webqa.  PROD_READY


Note You need to log in before you can comment on or make changes to this bug.