Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158231 - Misc. "system-config-lvm" issues
Summary: Misc. "system-config-lvm" issues
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 159754
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 18:56 UTC by Wendy Cheng
Modified: 2010-01-12 04:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-03 21:00:46 UTC


Attachments (Terms of Use)

Description Wendy Cheng 2005-05-19 18:56:04 UTC
Description of problem:

Rob Kenna, Jonathan Brassow, and Lon Hohberger put togather a RHEL 4 cluster/GFS
class on 5/18/05 with a hand-on lab exercise for GSS group. This bugzilla
documents the problems (on system-config-lvm) we found during the exercise.
Though most of them were trivial issues, these do represent the "look and feel"
of the product that real customers are going to see. 

3. The "vgcreate" in system-config-lvm
   (severity very low)(easy to fix)(easy workaround if known in advance)
                                                                                
The "Filesystem" field in "Create a New Logical Volume" panel is confusing. It
offers three choices: "No Filesystem", "Ext2", "Ext3". We didn't try out how
Ext2 and Ext3 work but we were on GFS installation. Doing a wild guess, we
choose "No Filesystem" and it *did* work. The general consensus in the class
room is that this would be better off rename to "No Filesystem or GFS".        
                                                                      
 
4. Editing of /etc/lvm/lvm.conf File
   (severity low)(not a bug but a usability issue)
                                                                                
4.1 It is not clear (to us) that the /etc/lvm/lvm.conf file need to get edited
on *every* node in the same GFS cluster.
4.2 Jumping in/out of GUI (system-config-lvm) to add the following lines into
lvm configuration file is awkward.
                                                                                
    # Type of locking to use. Defaults to file-based locking (1).
    # Turn locking off by setting to 0 (dangerous: risks metadata corruption
    # if LVM2 commands get run concurrently).
    locking_type = "2"
    locking_library = "/usr/lib/liblvm2clusterlock.so"

It would be nice to include the above two into system-config-lvm tool (consider
this as a feature request). On the other hand, make really sure these two are
documented in SysAdmin guide (if we have one).
                                                                                
Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Wendy Cheng 2005-05-19 18:59:18 UTC
Sorry, Item 1) and 2) are opened against system-config-cluster component
(bugzilla 158230). Forgot to reset the numbering. 

Comment 2 AJ Lewis 2005-06-07 20:05:58 UTC
Item 4 is being addressed in bug #159754


Note You need to log in before you can comment on or make changes to this bug.