Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158230 - system-config-cluster GUI interface issues
Summary: system-config-cluster GUI interface issues
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
: 159840 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 18:45 UTC by Wendy Cheng
Modified: 2009-04-16 20:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 18:52:04 UTC


Attachments (Terms of Use)

Description Wendy Cheng 2005-05-19 18:45:39 UTC
Description of problem:

Rob Kenna, Jonathan Brassow, and Lon Hohberger put togather a RHEL 4 cluster/GFS
class on 5/18/05 with a hand-on lab exercise for GSS group. This bugzilla
documents the problems (on system-config-cluster) we found during the exercise.
Though most of them were trivial issues, these do represent the "look and feel"
of the product that real customers are going to see. 

1. Configuration File
   (severity high)(easy to fix)(easy workaround if known in advance).
                                                                                
The "system-config-cluster" tool can't save its configuration data into
/etc/cluster/cluster.conf file due to the non-existence of /etc/cluster
directory. The subject directory should be either auto-created by rpm install
and/or the system-config-cluster should be able to handle the empty directory
scenario.
                                                                                
2. Fence Device GUI interface
   (severity low)(easy to fix)(easy workaround if known in advance)
                                                                                
2.1 The fields of fence device input panel are very misleading. The "Hostname"
should have been IP Address and the "Name" should have been something more
obviously labelled (maybe "Label" or even "Hostname" ?).

2.2 "Name" rule is not well known. One thing we noticed is that it doesn't take
"_" (say "star_war" got bounced back).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jim Parsons 2005-05-20 17:41:37 UTC
Issue 1 has been rectified. Not certain about what to do with Issue 2, as the
gui names reflect the names of the attributes in the xml file, which in turn
reflect the names of the fields in the man pages. It seems like these all need
to kinda line up - just to avoid confusion. anyway, they are super easy to
change in the ui.

As far as underscores go, they should be OK. Refiling this as a separate bug.

Comment 2 Corey Marthaler 2005-05-31 18:52:04 UTC
Verified a fix for issue 1 and 2.2. 

If issue 2.1 is really a big deal then a seperate bug should be filed for it.

Comment 3 Corey Marthaler 2005-06-13 19:12:46 UTC
*** Bug 159840 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.