Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158225 - httpd -S (show settings) provides no output
Summary: httpd -S (show settings) provides no output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 18:30 UTC by Andrew Taylor
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.0.54-10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 14:13:16 UTC


Attachments (Terms of Use)

Description Andrew Taylor 2005-05-19 18:30:45 UTC
Running "httpd -S" to diagnose virtual host errors doesn't provide any output. 
This is related to bug 145822 and is caused by SELinux restrictions on accessing
the terminal.

A work around is to pipe stderr through cat: "httpd -S 2>&1 | cat".

It would be nice if Fedora Core provided an alternate way to run httpd
interactively, without swallowing output.  e.g. "apachectl showsettings"

Comment 1 Joe Orton 2005-05-20 14:34:20 UTC
I'd rather not change the apachectl interface vs upstream.  Would e.g.

  "service httpd dumpconfig"

be OK?  I think this would probably be useful.

Comment 2 Andrew Taylor 2005-05-20 16:40:19 UTC
That would be ok for me.  One problem with this solution (and the apachectl fix,
too) is that it isn't very discoverable.  Someone familiar with apache, or
having read the apache docs, will try "httpd -S" and expect it to work.  And
without console output, it isn't possible to redirect them to an alternative.

Maybe the bug is really part of the SELinux policy?  Can it not allow httpd to
output to the terminal if started with interactive commandline parameters?

Comment 3 Joe Orton 2005-09-05 14:13:16 UTC
Yes, this is caused by the SELinux policy; in fact in FC4 the policy was relaxed
so this does work by default.


Note You need to log in before you can comment on or make changes to this bug.