Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158221 - rpmbuild --target ppc64 builds ppc32 binaries
Summary: rpmbuild --target ppc64 builds ppc32 binaries
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm
Version: 4.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
: 167834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 18:05 UTC by David Lehman
Modified: 2010-06-07 05:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-07 05:12:13 UTC


Attachments (Terms of Use)

Description David Lehman 2005-05-19 18:05:48 UTC
+++ This bug was initially created as a clone of Bug #146155 +++

Description of problem:
Running rpmbuild --target ppc64 builds ppc32 objects but puts them in /lib64 and
calls the rpm a .ppc64.rpm. I seems CFLAGS and/or RPM_OPT_FLAGS are not being
set correctly.

Version-Release number of selected component (if applicable):
rpm-4.3.3-7_nonptl

How reproducible:
Always

Steps to Reproduce:
1. Grab any SRPM for which we ship a ppc64 package (eg: pcre)
2. run rpmbuild -bb --target ppc64 pcre.spec 
3.
  
Actual results:
rpmbuild creates a .ppc64.rpm containing 32-bit libraries in /usr/lib64

Expected results:
If it builds a ppc64 package the package should contain 64-bit objects

Additional info:

Comment 1 Jens Petersen 2006-01-05 10:00:54 UTC
-m64 is used with RHEL4U2 at least AFAICT.
Also I believe (for better or worse) rpmbuild defaults to ppc64
on our powerpc os currently too FWIW.

Comment 2 Jeff Johnson 2006-02-12 15:47:38 UTC
*** Bug 167834 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2006-08-06 22:09:30 UTC
This problem is like fixed (by setting arch from --target) in rpm-4.4.7-0.15.

UPSTREAM


Note You need to log in before you can comment on or make changes to this bug.