Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158215 - rpmrc and ppc64pseries and ppc64iseries macros files are broken
Summary: rpmrc and ppc64pseries and ppc64iseries macros files are broken
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm
Version: 3.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 17:14 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:01:58 UTC


Attachments (Terms of Use)

Description David Lehman 2005-05-19 17:14:34 UTC
Description of problem:
anaconda writes the canonical arch into /etc/rpm/platform. rpm uses this arch by
default when doing package builds. The problem is that the macros files for the
canonical arches are wrong. They don't define %_multilibno and %optflags is wrong.

More importantly, rpmrc doesn't have the correct buildarchtranslate entries for
ppc64pseries and ppc64iseries. 

Version-Release number of selected component (if applicable):
rpm-4.2.3-21_nonptl

How reproducible:
Always

Steps to Reproduce:
1. try to rebuild any package on a pSeries without using --target
2.
3.
  
Actual results:
The resulting package will be .ppc64pseries.rpm

Expected results:
The resulting package should be .ppc.rpm

Additional info:

Comment 5 RHEL Product and Program Management 2007-10-19 19:01:58 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.