Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158214 - MSN login in kopete fails with bad password error
Summary: MSN login in kopete fails with bad password error
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdenetwork
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
: 160424 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 17:07 UTC by Dennis Gilmore
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-14 12:41:21 UTC


Attachments (Terms of Use)
Patch to fix Kopete MSN login for kdenetwork-3.3.1 (deleted)
2005-05-22 10:33 UTC, Harry
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 105929 None None None Never

Description Dennis Gilmore 2005-05-19 17:07:56 UTC
Description of problem: 
When kopete attempts to login to MSN servers login fails with bad password 
error. While the password is indeed correct. 
 
 
Version-Release number of selected component (if applicable): 
kdenetwork-3.4.0-3 
 
How reproducible: 
Always. 
 
Steps to Reproduce: 
1. create msn account in kopete 
2. attempt to login 
 
   
Actual results: 
login fails.  with bad password error. 
 
Expected results: 
successful login. 
 
Additional info: 
 
http://bugs.kde.org/show_bug.cgi?id=105929 
has additional info  including info on patch applied to svn tree

Comment 1 Harry 2005-05-22 10:33:55 UTC
Created attachment 114685 [details]
Patch to fix Kopete MSN login for kdenetwork-3.3.1

Due to my impatience I've back-ported the Kopete MSN login fix to FC3.	The
patch was created against kdenetwork-3.3.1 and then added to the
kdenetwork-3.3.1-3 FC3 package.  After building kdenetwork with the patch I
successfully logged into MSN with Kopete.

Comment 2 Harry 2005-06-01 08:12:59 UTC
Are there any plans to fix this bug for FC3?  Although I've managed to build a
patched version of kdenetwork-3.3.1-3 others may not be capable of doing this. 
It's approaching a fortnight since this bug was reported here.  Unfortunately
this is also the type of response I've seen from another distribution as well. 
Gaim appears to be updated frequency and Kopete not at all.

Comment 3 Peter Eddy 2005-06-01 16:20:02 UTC
I'd really appreciate this fix, Kopete's a nicer IM client for KDE users.

Comment 4 Gilles CHAUVIN 2005-06-14 11:30:19 UTC
This bug's still not fixed in Stentz.

(I wonder why FC4 comes with KDE 3.4.0 instead of 3.4.1 ?!)

Comment 5 Ngo Than 2005-06-14 12:41:21 UTC
This fix is included in new kde-3.4.1. I'm still packaging kde-3.4.1 for FC4 and
probably for FC3 . I hope it will be done this week. Many thanks for your report.

Comment 6 Ngo Than 2005-06-15 08:04:05 UTC
*** Bug 160424 has been marked as a duplicate of this bug. ***

Comment 7 Harry 2005-07-03 10:01:34 UTC
(In reply to comment #5)      
> This fix is included in new kde-3.4.1. I'm still packaging kde-3.4.1 for FC4      
and      
> probably for FC3 . I hope it will be done this week. Many thanks for your      
report.      
      
While I have since upgraded to FC4 I can't help but notice that kdenetwork     
still hasn't been patched for FC3.  It has   
been 8 weeks since I posted an example of a patch in a previous comment at   
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158214#c1 that I used in 
FC3. 

Comment 8 Ngo Than 2005-07-04 13:04:15 UTC
the new kdenetworl-3.3.1 including this fix will be pushed this week ;-)
Sorry for the delay


Note You need to log in before you can comment on or make changes to this bug.