Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158208 - Filter creation doesn't occur when filters window is open
Summary: Filter creation doesn't occur when filters window is open
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 16:06 UTC by Jack Aboutboul
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 22:27:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 304816 None None None Never

Description Jack Aboutboul 2005-05-19 16:06:13 UTC
Description of problem:
Creating a filter while the filter window is open will go through and complete
successfully, although the filter you are trying to will not ever be created. 

Version-Release number of selected component (if applicable):
2.0.4-4

How reproducible:
Always

Steps to Reproduce:
1. Open the filters window to view filters
2. Behind the open window try and create a filter
3. Filter dialog will close successfully
  
Actual results:
Filter dialog closes with no error yet no filter is created

Expected results:
Filter dialog should either close with an error or create the filter.

Additional info:

Comment 1 Dave Malcolm 2005-05-19 17:29:19 UTC
I just tried this in Evolution 2.2.2:
1: Open the filters window to view filters
2: Behind the open window try and create a filter (by right-clicking on an
email; Create Rule from Message->Filter on something... OK); filter does not
appear in the existing filter dialog.
3a: Press "Cancel" button in the filter dialog, reopen the filter dialog. 
Filter created in stage does appear in the new filter dialog
3b: Press "Ok" button in the filter dialog, reoper the filter dialog: filter
created in stage 2 does not appear.

So it looks like a the filter dialog really ought to update its state if you do
stage 2; arguably the filter dialog ought to be "instant apply" as well,
replacing the Cancel/OK buttons with a single "OK" button.

Please check upstream; if the bug is not already filed, please file one, and
link this bug to it.  Please CC me on the new or existing bug; thanks!

The upstream bug tracker is http://bugzilla.gnome.org


Note You need to log in before you can comment on or make changes to this bug.