Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158189 - makedbz segfault in %post script
Summary: makedbz segfault in %post script
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 14:10 UTC by Joe Orton
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-20 17:14:04 UTC


Attachments (Terms of Use)

Description Joe Orton 2005-05-19 14:10:38 UTC
Today's Raw Hide snapshot sees this error in install.log:

Installing inn-2.4.2-3.i386.
/var/tmp/rpm-tmp.42047: line 2:  9233 Segmentation fault      su news -c
'/usr/lib/news/bin/makedbz -i -o'

Comment 1 Martin Stransky 2005-05-20 08:14:49 UTC
Did you install inn package or did you upgrade it?
Makedbz segfaults if you have an old index data
(see https://bugzilla.redhat.com/bugzilla-old/show_bug.cgi?id=157802)

Comment 2 Joe Orton 2005-05-20 08:41:41 UTC
It was a completely fresh install.

Comment 3 Martin Stransky 2005-05-20 10:01:07 UTC
What happens if you run makedbz as root from command line?
Which files do you have in /var/lib/news ?


Comment 4 Joe Orton 2005-05-20 10:14:53 UTC
Ah, sorry, it's actually su which is segfaulting.

Tim this is reproducible on every rpm --erase inn / rpm -ivh inn invocation on a
Raw Hide box.  gdb says the crash is at:

(gdb) bt full
#0  0x009867e2 in main (argc=4, argv=0xbfe8d8c4) at su.c:344
        optc = Variable "optc" is not available.

coreutils-5.2.1-45

Comment 5 Tim Waugh 2005-05-20 12:30:57 UTC
This seems to be because ttyname(0) returns NULL.

Fixed package is coreutils-5.2.1-47.

Comment 6 Joe Orton 2005-05-20 13:11:21 UTC
Works for me, thanks Tim.


Note You need to log in before you can comment on or make changes to this bug.