Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158173 - MLDv2 uses wrong ICMP type: IPv6 multicast receiving broken
Summary: MLDv2 uses wrong ICMP type: IPv6 multicast receiving broken
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Miller
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 11:35 UTC by Pekka Savola
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:02:01 UTC


Attachments (Terms of Use)
Trivial patch to fix the problem. (deleted)
2005-05-19 11:35 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2005-05-19 11:35:55 UTC
Description of problem:

MLDv2 code uses wrong ICMP type, and in consequence, multicast receiving does
not work because the routers ignore the wrong type.  This has since then been
fixed in the later kernel releases, but apparently not in RHEL.

Version-Release number of selected component (if applicable):
kernel-2.4.21-32.EL

How reproducible:
1) run 'tcpdump -n -vvv -s0 icmp6'
2) start a v6 multicast application, for example 'ttcp -r ff1e::1'
3) observe that the ff1e::1 group shows in 'netstat -g -n' but the generated
   MLDv2 report uses a bogus ICMP type  #206, instead of #143
   (http://www.iana.org/assignments/icmpv6-parameters)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Pekka Savola 2005-05-19 11:35:56 UTC
Created attachment 114561 [details]
Trivial patch to fix the problem.

Comment 2 Pekka Savola 2005-05-19 12:06:06 UTC
Minor correction: the MLD report doesn't show with 'tcpdump icmp6' because
there's a hop-by-hop option; you must use 'tcpdump -XXXX ip6' instead.

Comment 3 Pekka Savola 2005-05-20 05:46:16 UTC
Additional observation after running with locally patched kernel for a while:
the MLDv2 implementation is severely broken, it doesn't seem to refresh the MLD
memberships, so the router forgets about the MLD reports for applications which
run for more than 5 minutes.

Thus, it might be beneficial to update the whole MLDv2 code from a newer 2.4
kernel, which is hopefully works a lot better, but just fixing the ICMP type
helps a bit as well.

Comment 4 Pekka Savola 2006-02-24 08:58:00 UTC
Any progress on this....?

Comment 5 RHEL Product and Program Management 2007-10-19 19:02:01 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.