Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158171 - netdump and netconsole will not start
Summary: netdump and netconsole will not start
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: netdump
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Graf
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 11:16 UTC by Herbert Gasiorowski
Modified: 2014-06-18 08:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-06 22:32:38 UTC


Attachments (Terms of Use)

Description Herbert Gasiorowski 2005-05-19 11:16:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414

Description of problem:
the module "netdump" is not found
and netconsole is started with wrong parameter

Version-Release number of selected component (if applicable):
netdump-0.7.7-6

How reproducible:
Always

Steps to Reproduce:
1.edit /etc/sysconfig/netdump
2./etc/init.d/netdump start
3.
  

Actual Results:  - the module netdump is not found
- netconsole is loaded with wrong parameters

Additional info:

netconsole is started in /etc/init.d/netdump
with "modprobe netconsole netlog=..."
instead of "modprobe netconsole netconsole=...".

This is the same in FC3

Comment 1 Jeremy Katz 2005-05-25 16:44:22 UTC
Are we missing kernel options here?

Comment 2 Jeff Moyer 2005-05-25 16:46:31 UTC
Davej dropped the netdump/netconsole kernel patches since they didn't apply w/o
fuzz.  I've since refactored the patches (last night), and hopefully dave will
incorporate them.

There is another issue, though, in that since the options passing differs
between RHEL and fedora, more logic may need to be put into the init script.

I'll test once I get a good kernel build (last one for me didn't boot).

Comment 3 Warren Togami 2005-05-30 22:13:15 UTC
Too late for FC4.  This must go out in an update.


Comment 4 Warren Togami 2006-03-06 15:38:01 UTC
What is the status of this?

Comment 5 Jeff Moyer 2006-03-06 18:36:09 UTC
service netdump start succeeds.  netconsole appears to function.  netdump fails
on the one system I tried (3com card, 3c59x driver).

Comment 6 Warren Togami 2006-03-06 22:32:38 UTC
Both netconsole and netdump fail on many specific drivers under various
conditions.  This is nothing new, and they are really driver problems.  Closing
this UPSTREAM.  Might be best to file individual bugs against each driver/card
combination that fails with netconsole or netdump.



Note You need to log in before you can comment on or make changes to this bug.