Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158170 - kernel 2.6.11-1_14_FC3 panics when paging to md-device
Summary: kernel 2.6.11-1_14_FC3 panics when paging to md-device
Keywords:
Status: CLOSED DUPLICATE of bug 158164
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 11:15 UTC by Frank Wittig
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-21 07:04:52 UTC


Attachments (Terms of Use)

Description Frank Wittig 2005-05-19 11:15:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
After updating to kernel 2.6.11-1_FC3 I got a kernel panic every time the kernel tried to page the first byte to the swap-partition.
Swap lies resides on /dev/md1 which is a level 1 raid device over two parallel ata disks (both master of 1st/2nd channel).
There's no way of getting arround this failure but downgrading to an older version of the kernel. Older versions never crash on my system during paging to swap.

I'm working to reproduce the failure on another machine and will post kernel messages when I have more information.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1_14_FC3

How reproducible:
Always

Steps to Reproduce:
1. setup swap partition on md-device
2. Upgrade to kernel-2.6.11-1_14_FC3
3. use as much memory it needs to make the kernel page to disk

Actual Results:  kernel panic occured

Expected Results:  kernel should have paged to disk

Additional info:

Comment 1 Dave Jones 2005-05-21 07:04:52 UTC

*** This bug has been marked as a duplicate of 158164 ***


Note You need to log in before you can comment on or make changes to this bug.