Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158168 - file /usr/share/texmf/tex/latex/xcolor/xcolor.sty from install of > tetex-xcolor-2.02-3.fc4 conflicts with file from package tetex-latex-3.0-4
Summary: file /usr/share/texmf/tex/latex/xcolor/xcolor.sty from install of > tetex-xco...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex-xcolor
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jose Pedro Oliveira
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 161257 (view as bug list)
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-05-19 11:07 UTC by Neal Becker
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-26 09:37:58 UTC


Attachments (Terms of Use)

Description Neal Becker 2005-05-19 11:07:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
file /usr/share/texmf/tex/latex/xcolor/xcolor.sty from install of 
> tetex-xcolor-2.02-3.fc4 conflicts with file from package tetex-latex-3.0-4 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. yum install tetex-xcolor 
2. 
3. 
   

Additional info:

Comment 1 Jose Pedro Oliveira 2005-05-19 19:29:22 UTC
The following Extras tetex packages are no longer needed

   * tetex-xcolor
   * tetex-pgf
   * tetex-beamer

The above three LaTex packages are now included in TeTeX 3.0.

Example:

# rpm -ql tetex-latex | grep xcolor
/usr/share/texmf/tex/latex/pgf/xxcolor.sty
/usr/share/texmf/tex/latex/xcolor
/usr/share/texmf/tex/latex/xcolor/svgnam.def
/usr/share/texmf/tex/latex/xcolor/xcolor.sty


Comment 2 Jose Pedro Oliveira 2005-05-19 19:50:33 UTC
Now the strange part:

Last week I installed a clean FC4 test3 system (custom install).  I can yum
install tetex-{beamer,pgf,xcolor} without problems.

I tested this with  "tetex-latex-3.0-3" included in FC4 Test3. Then removed
every tetex package and installed "tetex-latex-3.0-4" from rawhide.  After this
tetex update I managed to yum install tetex-{beamer,pgf,xcolor} again without
problems.

This can happen if:
1) the file has the same MD5 digest in both rpms (tetex-latex and tetex-xcolor)
2) something is broken in yum/rpm


# rpm -V tetex-xcolor
(no output)
# rpm -V tetex-latex
........C   /usr/bin/latex
........C   /usr/bin/pdflatex
S.5....T.   /usr/share/texmf/tex/latex/xcolor/svgnam.def
S.5....T.   /usr/share/texmf/tex/latex/xcolor/xcolor.sty

Ouch! Different MD5 digests.

# rpm -q tetex tetex-latex tetex-xcolor yum rpm
tetex-3.0-4
tetex-latex-3.0-4
tetex-xcolor-2.02-3.fc4
yum-2.3.2-2
rpm-4.4.1-18.1


Comment 3 Jose Pedro Oliveira 2005-05-19 20:00:02 UTC
Manually installing the tetex-xcolor with the rpm command generates the expected
conflict.

# rpm -qa | grep ^tetex | xargs rpm -e
# rpm -ivh tetex-3.0-4.i386.rpm tetex-latex-3.0-4.i386.rpm
tetex-fonts-3.0-4.i386.rpm tetex-dvips-3.0-4.i386.rpm
#  rpm -ivh tetex-xcolor-2.02-3.fc4.noarch.rpm
...
       file /usr/share/texmf/tex/latex/xcolor/svgnam.def from install of
tetex-xcolor-2.02-3.fc4 conflicts with file from package tetex-latex-3.0-4


Something is broken in yum (force installing by default? configuration?)



Comment 4 Jose Pedro Oliveira 2005-05-19 20:10:05 UTC
Removal request of
  tetex-xcolor
  tetex-pgf
  tetex-beamer
from the development branch added to 
  http://fedoraproject.org/wiki/Extras_2fCVSSyncNeeded

Comment 5 Jose Pedro Oliveira 2005-05-19 20:14:32 UTC
Michael or Warren,

I believe the FC4 tetex package should also be updated (the tetex package in FC3
didn't include xcolor, pgf, and beamer LateX packages).

Shouldn't it include something like:
...
Obsoletes: tetex-xcolor
Obsoletes: tetex-pgf
Obsoletes: tetex-beamer
...


Comment 6 Jose Pedro Oliveira 2005-05-21 03:11:59 UTC
Warren,

Could you see comments #1 and #5?

I think this may me a FC4 blocker as it may break upgrades from FC3 with the
above Extras tetex packages installed (tetex-xcolor, tetex-pgf, and tetex-beamer).

Should I open a ticket against Fedora Core tetex package?

Comment 7 Michael Schwendt 2005-05-21 10:08:10 UTC
In general, file conflicts in existing packages don't prevent an upgrade from
happening. The files would be overwritten. But nothing in the upgrade process
would remove the Extras packages, which would be unclean.

Comment 8 Jose Pedro Oliveira 2005-06-21 20:01:50 UTC
Same problem but in the tetex core package
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160754

Comment 9 Jose Pedro Oliveira 2005-06-21 20:02:45 UTC
*** Bug 161257 has been marked as a duplicate of this bug. ***

Comment 10 Michael Schwendt 2005-07-26 09:37:58 UTC
Packages have been removed at last.


Comment 11 Jose Pedro Oliveira 2005-07-26 16:08:26 UTC
Thanks Michael!


Note You need to log in before you can comment on or make changes to this bug.