Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158167 - yum will not upgrade package from FC3 to FC4
Summary: yum will not upgrade package from FC3 to FC4
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 11:02 UTC by Markus Wigge
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 07:43:35 UTC


Attachments (Terms of Use)

Description Markus Wigge 2005-05-19 11:02:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When upgrading from FC3 to FC4test3 this package was not upgraded because it has the same version and release as the old FC3 package!

This lead to trouble with other packages too, in my case I had a conflict with ethereal and net-snmp{,-libs} which also have the same version and release but different dependancies!

yum cannot solve this, so these packages should get an newer release-number!


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC3 with vixi-cron, ethereal, net-snmp
2. Update to latest bugfix-releases
3. rpm -Uvh http://download.fedora.redhat.com/pub/fedora/linux/core/test/3.92/i386/os/Fedora/RPMS/fedora-release-3.92-1.i386.rpm
4. upgrade to newest kernel and remove old one (because auf kernel-utils dependency)
5. yum upgrade
-> this will lead to unresolved dependencies with net-snmp and ethereal!
-> after successful upgrade vixie-cron will still be "FC3"!

  

Actual Results:  It must be upgraded by hand

Expected Results:  All packages should upgrade automatically. Don't know if there are more.

Additional info:

Comment 1 James Bourne 2005-05-19 14:45:08 UTC
verified conflict with net-snmp-5.2.1-10.FC3.

Comment 2 Radek Vokal 2005-05-23 07:43:35 UTC
True, those two packages got rebuilt in devel branch first and than I added .FC3
for an Fedora Core 3 update - so packages are not old, they are same. This will
get fixed with next devel release and I'll try not to do this again :) 


Note You need to log in before you can comment on or make changes to this bug.