Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158156 - Assertion (metadata_length > 0) at disk_dos.c: 1942 ... failed
Summary: Assertion (metadata_length > 0) at disk_dos.c: 1942 ... failed
Keywords:
Status: CLOSED DUPLICATE of bug 138419
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 08:26 UTC by dj
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 12:24:03 UTC


Attachments (Terms of Use)

Description dj 2005-05-19 08:26:36 UTC
Description of problem:
When installing FC4T3 I got the following error message. It pops up twice always
and it doesn't seem to make any difference, if you click "ignore" or "cancel"
afterwards.

The message is: "Assertion (metadata_length > 0) at disk_dos.c: 1942 in function
add_logical_part_metadata() failed."

On the console there is also "96" printed on the next line after those messages.

After all, FC4T3 installed and can be booted fine.

How reproducible: Always.

Steps to Reproduce:
1. Boot from DVD. (Media check says it's fine.)
2. Select German language (worked for English, too)
3. Select German keyboard layout without deadkeys (worked for en_US, too)
  
Actual results:
Two popup windows (one after the other) with the mentioned error message.

Expected results:
If this assertion points to a hardware integrity problem, the user should be
informed so they can backup their data.

Additional info: During the same install, my partition table got damaged. See
bug #158017 for further information on that. I don't know, if they are related.

Comment 1 Jeremy Katz 2005-05-19 12:24:03 UTC

*** This bug has been marked as a duplicate of 138419 ***


Note You need to log in before you can comment on or make changes to this bug.