Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158142 - Multiple problems with Evolution v. OpenLDAP 2.2.13-2 (FC3)
Summary: Multiple problems with Evolution v. OpenLDAP 2.2.13-2 (FC3)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 02:12 UTC by Bojan Smojver
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 07:35:05 UTC


Attachments (Terms of Use)

Description Bojan Smojver 2005-05-19 02:12:41 UTC
Description of problem:

Problem 1: The dialog box for editing LDAP address books is only capable of
adding address books. Changes made to existing LDAP address books don't seem to
be taking effect (actually, when properties are pulled again, old values are
displayed). I'm guessing this is a GUI issue.

Problem 2: Evolution 2.2.2-5 seems incapable of talking SSL with FC3 shipped
OpenLDAP servers. Whenever I set an address book up with SSL settings of
"Always" or "Whenever possible", Evo displays an error message along the lines
of "can't talk to the LDAP server".

Version-Release number of selected component (if applicable):
2.2.2-5

How reproducible:
Always.

Steps to Reproduce:

Problem 1:
1. Set up an LDAP address book.
2. Right click it and go to properties.
3. Change values and see which ones stick. Many don't

Problem 2:
1. Add a new LDAP server with SSL connection.
2. Attempt to use it.
  
Actual results:
Problem 1: Values don't stick.

Problem 2: No connection can be made to OpenLDAP via SSL.

Expected results:
Should work, as it used to in Evo 2.0.

Additional info:
Let me know what kind of debugging info I can send in.

Comment 1 Bojan Smojver 2005-05-19 02:28:19 UTC
May be of interest... Thunderbird picks up the addressbook via SSL just fine. It
can't edit anything in it, but I think that's not a feature of Thunderbird anyway.

BTW, I also noticed that attempts to add contact entries into LDAP via
unecrypted connection through Evolution result in evolution-data-server
crashing. Something is really screwed with this version of Evo...

Comment 2 Bojan Smojver 2005-05-19 05:38:31 UTC
Looks like problem one is related to this:

http://bugzilla.gnome.org/show_bug.cgi?id=274393

But I'd say there is more to it. It seems impossible to change the port after
it's been initially set as well.

Comment 3 Bojan Smojver 2005-05-19 05:39:27 UTC
evolution-data-server crash here:

http://bugzilla.gnome.org/show_bug.cgi?id=303685

Comment 4 Bojan Smojver 2005-05-19 05:42:03 UTC
SSL problem may be related to this:

http://bugzilla.gnome.org/show_bug.cgi?id=268826

Comment 5 Bojan Smojver 2005-05-19 07:35:05 UTC
Will refile as a new bug, without the SSL bit, which seems to be more of an
integration issue than anything.


Note You need to log in before you can comment on or make changes to this bug.