Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158140 - aiksaurus-gtk: Icon missing from gnome-gaiksaurus.desktop
Summary: aiksaurus-gtk: Icon missing from gnome-gaiksaurus.desktop
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: aiksaurus
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marc Maurer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-19 01:02 UTC by Jack Spaar
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-16 12:38:09 UTC


Attachments (Terms of Use)
Desktop file icon (deleted)
2006-01-25 01:24 UTC, Brian Pepple
no flags Details
Spec File Patch (deleted)
2006-01-25 02:26 UTC, Brian Pepple
no flags Details | Diff
Desktop file for aiksaurus (deleted)
2006-01-25 02:29 UTC, Brian Pepple
no flags Details

Description Jack Spaar 2005-05-19 01:02:09 UTC
Description of problem:
gaiksaurus appears in the Hat->Accessories menu (as Thesaurus) with no icon.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install aiksaurus-gtk-1.2.1-5
2. notice missing icon for panel->hat->accessories->Thesaurus
3.
  
Actual results:


Expected results:


Additional info:
Icon is not specified in /usr/share/applications/gnome-gaiksaurus.desktop

Comment 1 Lars G 2005-06-11 19:23:36 UTC
me too

Comment 2 Brian Pepple 2006-01-25 01:24:18 UTC
Created attachment 123643 [details]
Desktop file icon

I've converted the .icns file in the tarball to a 48x48 .png, so you can use
that for the .desktop icon.  It'd be nice to fix this before FC5 comes out.

Comment 3 Brian Pepple 2006-01-25 02:26:14 UTC
Created attachment 123644 [details]
Spec File Patch

I've gone ahead and created a patch to your spec file to add the desktop icon. 
In addition, the patch fixes a bunch of compliance issues with the spec (proper
handling of desktop, sub-package dependencies, etc).  Also, instead of adding a
desktop file by use of a patch, I adding it by SOURCE since everything can be
handled in the desktop-file-install call.

Comment 4 Brian Pepple 2006-01-25 02:29:20 UTC
Created attachment 123645 [details]
Desktop file for aiksaurus

Comment 5 Marc Maurer 2006-02-16 12:38:09 UTC
Patch applied, thanks. Sorry for the delay.


Note You need to log in before you can comment on or make changes to this bug.