Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158139 - system-config-keyboard does not allow for the selection of any Indic keyboard layouts
Summary: system-config-keyboard does not allow for the selection of any Indic keyboard...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhpl
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On: 130853
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-05-19 00:29 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
3 users (show)

Fixed In Version: RHBA-2005-594
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 15:29:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:594 qe-ready SHIPPED_LIVE anaconda bug fix update 2005-10-05 04:00:00 UTC

Description Lawrence Lim 2005-05-19 00:29:44 UTC
+++ This bug was initially created as a clone of Bug #130853 +++

Description of problem:
If a user for any Indic language wishes to switch the keyboard layout
to that of his language, it cannot be done thru system-config-keyboard. 
It is not possible to select multiple keyboard layouts using this applet. 


Version-Release number of selected component (if applicable):
0.145


How reproducible:
Every time


Steps to Reproduce:
1. Run system-config-keyboard as root
2.
3.
  

Actual results:
- Cannot switch to any indic keyboard layout (no options available)
- Cannot select multiple layouts


Expected results:
- should be able to select indic keyboard layouts
- should be able to select multiple layouts


Additional info:
Currently, there are no indic keyboard layouts available to select in
system-config-keyboard.
Multiple layout selection is essential for indic languages, since all
indic users switch between indic and english very often. 
All of these capabilities are available in the keyboard applet of
gnome preferences.

Comment 1 Lawrence Lim 2005-05-19 00:34:49 UTC
In EL4, 4 out of 5 supported Indic has been fixed. Only Punjabi (Inscript) still
has a slight problem (option shift_toggle not set).

Fix has this bug has been incorporated in rhpl-0.164-1 for FC4.

Comment 5 Jeremy Katz 2005-07-08 21:41:10 UTC
Fixed

Comment 8 Red Hat Bugzilla 2005-10-05 15:29:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-594.html



Note You need to log in before you can comment on or make changes to this bug.