Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158138 - gui login does not process login and password
Summary: gui login does not process login and password
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC4Update
TreeView+ depends on / blocked
 
Reported: 2005-05-18 23:36 UTC by Kirk C Aune
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-30 20:40:58 UTC


Attachments (Terms of Use)

Description Kirk C Aune 2005-05-18 23:36:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
Its BAAAAAK ...
The same prompting for login and password followed by a fresh login screen has returned.   I had not removed the selinux=0 from my grub kernel line so that is not the issue this time.   I see the same messages I reported the last time in my messages log regarding processing of characters in gdmgreeter. A snippet follows:May 18 18:08:30 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:30 mozart gdmgreeter[3658]: args for opcode 'N' are 'Username:'
May 18 18:08:30 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:33 mozart gdmgreeter[3658]: args for opcode 'D' are ''
May 18 18:08:33 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:33 mozart gdmgreeter[3658]: args for opcode 'l' are 'kaune'
May 18 18:08:33 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:33 mozart gdmgreeter[3658]: args for opcode 'U' are 'Password:'
May 18 18:08:33 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:39 mozart gdmgreeter[3658]: args for opcode 'D' are ''
May 18 18:08:39 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:39 mozart gdmgreeter[3658]: args for opcode 'e' are ''
May 18 18:08:39 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:39 mozart gdmgreeter[3658]: args for opcode 'l' are 'kaune'
May 18 18:08:39 mozart gdmgreeter[3658]: processed 1 messages
May 18 18:08:40 mozart gdm(pam_unix)[3615]: session opened for user kaune by (uid=0)
May 18 18:08:40 mozart gdmgreeter[3658]: args for opcode 'G' are 'default.desktop'
May 18 18:08:40 mozart gdmgreeter[3658]: Unexpected greeter command received: ''
May 18 18:08:40 mozart gdm(pam_unix)[3615]: session closed for user kaune
--More--


Version-Release number of selected component (if applicable):
gdm-2.6.0.8-14

How reproducible:
Always

Steps to Reproduce:
1.Enter username 
2.Enter password
3.See gui refresh and reprompt
  

Actual Results:  I tried removing selinux=0 in my boot up.  I tried 1315_FC4 kernel and my own 2.6.12-rc4 kernel.  No difference.   I logged in on a virtual terminal so that I could gather the data, remove gdm-2.6.0.8-14 and reinstall the gdm from FC4-test2 (gdm-2.6.0.8-1) to restore my gui login.



Expected Results:  a login under the new gui

Additional info:

see above

Comment 1 Ray Strode [halfline] 2005-05-19 18:12:41 UTC
If you upgrade to the gdm in tommorrow's rawhide do you still see the problem? 
Does it only not work with your username or with any user?

Comment 2 Kirk C Aune 2005-05-19 18:49:18 UTC
I have my root user and  J. Random User (kaune) as well as one other J. Random
User (which I have not tried)  I will try the latter later when I replace my
current old gdm (2.6.0.8-1) with 2.6.0.8-14 again.   BTW, the failure occurred
again today when I allowed the gdm to be replaced again in the update along with
about 41 other updates.

I am assuming you mean literally tomorrow 5/20/2005 for an update.   I will be
checking for any update up until midnight tonight, but unfortunately will be
unable to provide new information for several days after that since I will be
away from this system for a few days.

The only thing I can say is that this problem is identical to the one I reported
a few weeks ago, and that was corrected by inserting selinux=0 on the boot
command line as you had suggested.  The bug report was labelled resolved and I
never noted the number.

Comment 3 Kirk C Aune 2005-05-19 19:09:50 UTC
I performed a
init 3
rpm -ev gdm-2.6.0.8-14
rpm -ivh --nodeps gdm-2.6.0.8-1.i386.rpm
init 5

Login as root, my usual non privileged user kaune, and then my rarely used other
non privileged user all failed to login, cycling with a refreshed gui login
prompt after entry of user and password.

I am now back to gdm-2.6.0.8-1 until I have other suggestions.   Sorry about
being unavailable for a few days.

Comment 5 Kirk C Aune 2005-05-28 14:33:22 UTC
Problem has been resolved with new updates.  Interestingly is that my older
compile of linux-2.6.12-rc4 continued to fail.   HOWEVER, a fresh compile (under
1363_FC4) of linux-2.6.12-rc5 works just fine.  Thank you for what has changed!
  I regard matter as resolved (but not understood!)

Comment 6 Ray Strode [halfline] 2005-05-30 20:40:58 UTC
Great.  I commited some changes to message processing that I thought might fix
this.  I'm glad it's working for you.


Note You need to log in before you can comment on or make changes to this bug.