Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158111 - slapd doesn't listen for ldaps when started from /etc/init.d/ script
Summary: slapd doesn't listen for ldaps when started from /etc/init.d/ script
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-18 19:28 UTC by Thomas J. Baker
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.2.23-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 21:46:48 UTC


Attachments (Terms of Use)

Description Thomas J. Baker 2005-05-18 19:28:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
Clean FC4T3 install plus 5/17 updates. Starting ldap works fine, no errors, but it's not listening to the ldaps port. I get connection refused. Starting it from the command line by hand like this works:

/usr/sbin/slapd -u ldap -h 'ldap:/// ldaps:///'

Seems the problem is with the quoting of the -h option. The FC3 init script had 

 daemon ${slapd} -u ldap -h '"ldap:/// ldaps:///"' $OPTIONS $SLAPD_OPTIONS

where the fc4 has 

 daemon ${slapd} -u ${user} -h "ldap:/// ldaps:///" $OPTIONS $SLAPD_OPTIONS

For some reason, you can't just replace the FC4 line with the working FC3 line.
The script processing has changed somehow.

Version-Release number of selected component (if applicable):
openldap-servers-2.2.23-4

How reproducible:
Always

Steps to Reproduce:
1.install openldap-servers
2.configure for ldaps and start
3.try to connect
  

Actual Results:  connection refused

Expected Results:  normal secure connection

Additional info:

Comment 1 Nalin Dahyabhai 2005-05-19 17:19:17 UTC
Are you by any chance using this with a version of initscripts from FC3?  The
quoting rules for the daemon() function changed.  Adding a requirement on the
right initscripts version should stop this from happening accidentally.

Comment 2 Thomas J. Baker 2005-05-19 18:41:06 UTC
"Clean FC4T3 install plus 5/17 updates." I'm using FC4. I only mentioned the FC3
stuff because it I had a backup and could compare.

Comment 3 Nalin Dahyabhai 2005-05-19 19:30:31 UTC
Agreed, newer initscripts (where "newer" isn't pinned down yet) seems to have
broken the ability to pass arguments with embedded whitespace to daemon().

Comment 4 Nalin Dahyabhai 2005-05-19 21:46:48 UTC
Should be fixed in 2.2.23-5 and later.  Please reopen this bug if you find that
this is not the case.


Note You need to log in before you can comment on or make changes to this bug.