Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158108 - --with-cplusplus=no should be added to configure options
Summary: --with-cplusplus=no should be added to configure options
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: beecrypt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-18 19:02 UTC by David Juran
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-07 07:31:14 UTC


Attachments (Terms of Use)

Description David Juran 2005-05-18 19:02:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
--with-cplusplus=no should be added to the configure options in the specfile. Or the C++ code should be fixed to build with gcc4 (as it seems to be in the beecrypt cvs) and the C++ libraries should be included in the %files section.

Version-Release number of selected component (if applicable):
beecrypt-4.1.2-8

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild beecrypt-4.1.2-8.src.rpm 

  

Additional info:

Comment 1 Panu Matilainen 2007-08-07 07:31:14 UTC
This has been done ages ago, nobody just remembered to close the bug:
* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
- Use -with-cplusplus=no. The libs still require libstdc++, so
  this needs further cleanup.



Note You need to log in before you can comment on or make changes to this bug.