Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158085 - e-d-s rpm spec has some bugs
Summary: e-d-s rpm spec has some bugs
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 4
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2005-05-18 15:04 UTC by Aaron Gaudio
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: evolution-2.8.0-7.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-11-27 03:47:59 UTC

Attachments (Terms of Use)

Description Aaron Gaudio 2005-05-18 15:04:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Galeon/1.3.20

Description of problem:
The spec file for e-d-s 1.2.2 release 2 contains at least one error and one uncessary hard-coded version string:

soup_version is defined as 2.2.2, but this release of e-d-s apparently requires libsoup 2.2.3 or greater (the configure step will fail without it).

mozilla_build_version is defined as 1.7.6, although 1.7.8 is the latest version of mozilla in FCtest4. There's no reason to hard-code this in the spec file....

%define mozilla_build_version %(pkg-config --modversion mozilla-nss)

will work better, and will always pick up the latest version. If you want to ensure someone doesn't use an old version of mozilla, you could use a hard-coded BuildReq of 'mozilla-nss-devel >= 37:1.7.3' (same for mozilla-nspr-devel), but the mozilla_build_version is used to tell e-d-s where the mozilla headers are, and that requires the actual version currently installed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. With libsoup 2.2.2 installed (hint it's *not* the latest in FCtest4), try rpm --rebuild the e-d-s sprm.

Actual Results:  Configure will fail because e-d-s requires at least 2.2.3.

Expected Results:  Spec should have an updated build requirement of libsoup 2.2.3, so trying to rebuild the rpm with libsoup 2.2.2 will result in a dependency error.

Additional info:

Also, with the latest mozilla package from FCtest4, configure will fail because it can't find the mozilla nspr headers under 1.7.6 (cause they don't exist). This happens before the libsoup problem is hit.

Comment 1 Dave Malcolm 2005-05-18 17:07:50 UTC
Thanks for this report.

I'm rebuilding with:
- updated (hardcoded) libsoup requirement (reflecting the value in
- removal of mozilla_build_version.  It now relies upon the pkg-config tests
from the to get the correct include and library paths, and so
should work with whatever version of mozilla you're building against.

I'm trying to get this into the final FC4.

Comment 3 Matthias Clasen 2006-11-27 03:47:59 UTC
Closing, according to comment 1

Note You need to log in before you can comment on or make changes to this bug.