Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158083 - fig2dev doesn't handle UTF-8 input
Summary: fig2dev doesn't handle UTF-8 input
Keywords:
Status: CLOSED DUPLICATE of bug 158082
Alias: None
Product: Fedora
Classification: Fedora
Component: transfig
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-18 14:54 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-21 18:49:31 UTC


Attachments (Terms of Use)
A doctored .fig file with utf-8 text. Text on the right in PDF should then read "Mecanismos de protección" (deleted)
2005-05-18 14:54 UTC, Horst H. von Brand
no flags Details

Description Horst H. von Brand 2005-05-18 14:54:47 UTC
Description of problem:
Creating a .fig file with UTF-8 accented characters with xfig fails. Fixing the
texts up by hand and giving the result to fig2dev gives weird output.

Version-Release number of selected component (if applicable):
transfig-3.2.4-11

How reproducible:
Always

Steps to Reproduce:
1. Create tst.fig file with UTF-8 text
2. fig2dev -L pdf tst.fig > tst.pdf
3.
  
Actual results:
Junk text in tst.pdf file


Expected results:
Correct text

Additional info:
Workaround if to use the C locale.

Comment 1 Horst H. von Brand 2005-05-18 14:54:47 UTC
Created attachment 114510 [details]
A doctored .fig file with utf-8 text. Text on the right in PDF should then read "Mecanismos de protección"

Comment 2 Ngo Than 2005-12-21 18:49:31 UTC

*** This bug has been marked as a duplicate of 158082 ***


Note You need to log in before you can comment on or make changes to this bug.