Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158082 - xfig doesn't handle UTF-8
Summary: xfig doesn't handle UTF-8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xfig
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
: 158083 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-18 14:45 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-21 18:50:19 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2005-05-18 14:45:33 UTC
Description of problem:
Creating a figure with text including accented characters is not possible with xfig

Version-Release number of selected component (if applicable):
xfig-3.2.4-10

How reproducible:
Always

Steps to Reproduce:
1. LANG=en_US.UTF-8 environment (FC default), start xfig
2. Select text input
3. Input an accented character
  
Actual results:
No accents


Expected results:
Correct text

Additional info:
fig2dev (from transfig-3.2.4-11) doesn't handle UTF-8 either (the .fig files are
text...)

A workaround is to use the C locale.

Comment 1 Ngo Than 2005-12-21 18:49:38 UTC
*** Bug 158083 has been marked as a duplicate of this bug. ***

Comment 2 Ngo Than 2005-12-21 18:50:19 UTC
it's fixed in xfig-3.2.4-17, which will be in rawhide soon. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.