Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158067 - Key repeat doesn't work on synergy client
Summary: Key repeat doesn't work on synergy client
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: synergy
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 191320 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-18 13:10 UTC by Brian G. Anderson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-04 13:40:24 UTC


Attachments (Terms of Use)

Description Brian G. Anderson 2005-05-18 13:10:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 StumbleUpon/1.9993 Firefox/1.0.4

Description of problem:
Key repeat doesn't work on machine where a synergy client is running, but it works from the server.  

Version-Release number of selected component (if applicable):
synergy-1.2.2-3

How reproducible:
Always

Steps to Reproduce:
1.setup a synergy client and server  so that one can type on the server with input redirected to the client and attach the client to the server
2.hold down a key on the server and see the key repeat
3.hold down a key on the client and notice it doesn't repeat
  

Actual Results:  key repeat on the client doesn't work

Expected Results:  key repeat should work

Additional info:

I am using a stock readhat gnome desktop

Comment 1 Matthias Saou 2005-05-18 14:38:02 UTC
This seems like an upstream bug, probably not packaging related. Could you
please report it on synergy's sf.net tracker?

http://sourceforge.net/tracker/?atid=490467&group_id=59275&func=browse

Comment 2 Matthias Saou 2005-08-03 15:56:06 UTC
I'd be interested in knowing if this is fixed in 1.2.3.
Packages of 1.2.3 should be available in Extras real shortly.

Please let me know, as if I don't get more details, I'll probably close the bug
as "UPSTREAM" since this isn't a packaging issue in the first place.

Comment 3 Brian G. Anderson 2005-08-04 12:27:15 UTC
The problem hasn't gone away as of the most recent update 1.2.3-1.fc4

Comment 4 Brian G. Anderson 2005-08-04 12:45:41 UTC
I entered this upstream as bug 1251834 on sourceforge.net for the synergy project

Comment 5 Matthias Saou 2005-08-04 13:40:24 UTC
Thanks.
Let me know if I can easily backport a patch from here when/if the problem gets
fixed. Do you mind if I close this bug as UPSTREAM now?

Comment 6 Brian G. Anderson 2005-08-04 15:50:47 UTC
I guess you can close it.  How do inform you when a patch appears?

Comment 7 Matthias Saou 2005-08-04 16:25:30 UTC
You can just add a comment to this closed bug or send me a personal email directly.

Comment 8 Brian G. Anderson 2005-08-05 22:21:26 UTC
Actually I just got a response to the bug I filed over at sourceforge: not a
bug.  It has to work this way so that synergy client doesn't get in an endless
loop.  Key repeat at the client keyboard repeats if one moves the synergy server
cursor back to the service desktop.  FYI.

Comment 9 Matthias Saou 2006-05-12 11:19:58 UTC
*** Bug 191320 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.