Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158063 - gnome-volume-control mutes sound sometimes
Summary: gnome-volume-control mutes sound sometimes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-18 10:36 UTC by Thilo Pfennig
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-05 18:39:21 UTC


Attachments (Terms of Use)

Description Thilo Pfennig 2005-05-18 10:36:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
Sometimes the sound is muted. I have to change settings in gnome-volume-control then and then sound is there again

Version-Release number of selected component (if applicable):
gnome-media-2.10.2-1

How reproducible:
Sometimes

Steps to Reproduce:
1. reboot computer
2. login via GNOME
2. play sound

  

Actual Results:  no sound but sound card detected

Expected Results:  sound is played

Also i would expect to be able to control sound via "PCM", "PC Speaker" and "Master".

Additional info:

I now know what to do to change things back. I have a Via KT400 Mainboard, The volume is only controllable by "VIA DXS". Master and PCM volume does never change anything - also PC Speaker. I can mute "Master". But I can not mute "PCM" without stopping sound. if the sound is gone there is a check mark at "IEC958 Capture Monitor" and "PCM" is muted. I then have to unmark the Capture Monitor an unmute "PCM".

I don't know if gnome-media is the problem. Might it also be ALSA?

Comment 1 Thilo Pfennig 2005-05-18 10:40:12 UTC
BTW: I use the onboard sound.
 VIA Technologies, Inc. VT8233/A/8235 AC97 Audio Controller



Comment 2 Josef Kubin 2006-12-06 15:10:23 UTC
RHEL5 is similar problem but it only happens when gnome-volume-control is
running. When the volume slider on xmms is decreased into minimum, it mutes PCM
slider.
I'm able to reproduce the problem easily.

Comment 3 Bastien Nocera 2007-04-05 14:56:16 UTC
I don't understand what the problem is here. You're using the volume applet, and
it mutes the Master channel when the volume is set to 0 with another
application, right?

Or is the problem that the tracks aren't unmuted on startup?

Comment 4 Thilo Pfennig 2007-04-05 18:39:21 UTC
I am not using Fedora any more.


Note You need to log in before you can comment on or make changes to this bug.