Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158059 - Kernel 2.6.11-1.1312_FC4 breaks input from both synaptics and mouse
Summary: Kernel 2.6.11-1.1312_FC4 breaks input from both synaptics and mouse
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-18 09:33 UTC by Bojan Smojver
Modified: 2015-01-04 22:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-18 21:27:07 UTC


Attachments (Terms of Use)
X configuration file (deleted)
2005-05-18 09:33 UTC, Bojan Smojver
no flags Details
dmesg output of the 1305 kernel (deleted)
2005-05-18 21:20 UTC, Bojan Smojver
no flags Details

Description Bojan Smojver 2005-05-18 09:33:00 UTC
Description of problem:
After the upgrade to this development kernel (from 1305), mouse input does not
work any more (although both devices are configured - see xorg.conf), only
touchpad does.

Version-Release number of selected component (if applicable):
2.6.11-1.1312_FC4

How reproducible:
Always.

Steps to Reproduce:
1. Run X on this kernel with the attached xorg.conf on HP ZE4201 notebook.


Actual results:
Mouse doesn't work.

Expected results:
Both the touchpad and mouse should work, as they do with previously released
kernel, 1305.

Additional info:

Comment 1 Bojan Smojver 2005-05-18 09:33:00 UTC
Created attachment 114498 [details]
X configuration file

Comment 2 Dave Jones 2005-05-18 20:26:25 UTC
there are no changes betweem 1305 and 1312 that could explain this.
Can you paste a diff -u output between dmesg output of both kernels ?
They should be identical as far as the input layer is concerned.
The only changes were e1000 driver, slab poison detector, scsi geometry, serial
console, max num of cpus on x86-64, and updated audit patches.

was there an X update as well perhaps ? Maybe something changed there.


Comment 3 Bojan Smojver 2005-05-18 21:20:02 UTC
Created attachment 114535 [details]
dmesg output of the 1305 kernel

Comment 4 Bojan Smojver 2005-05-18 21:27:07 UTC
Just booted 1312 and both devices work.

So, the official cause of this bug is drug induced state of the reporter :-(

I have no idea now why it didn't want to work the first time I booted 1312...
Obviuosly, not a bug. Sorry for wasting resources before the release.


Note You need to log in before you can comment on or make changes to this bug.