Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158044 (EmacsFontLockProblem) - Emacs font-lock problems Tracker
Summary: Emacs font-lock problems Tracker
Keywords:
Status: CLOSED RAWHIDE
Alias: EmacsFontLockProblem
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On: 126165 148977 150197 155292
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-18 03:42 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 21.4-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-04 08:34:00 UTC


Attachments (Terms of Use)

Description Jens Petersen 2005-05-18 03:42:08 UTC
Description of problem:
There seem be quite a number of reports of highlighting problems
with Emacs font-lock-mode.  However I haven't been able to reproduce
any of them to date.  This tracker is to follow the issue and hopefully
gain some insight into the issue.

Comment 1 Jens Petersen 2005-05-18 05:51:16 UTC
Ok, this probably doesn't apply to bug 145759 (since that is for makefile-mode)
but I noticed this posting:
http://lists.gnu.org/archive/html/help-gnu-emacs/2004-11/msg00431.html
which suggests the font-lock problem may well be fixed in the latest cc-mode.
So in the next build I'm updating cc-mode to the latest release to see if that
helps with this problem.

Could you please test that or try installing the latest cc-mode locally
and see if it helps. (cc-mode is available at http://cc-mode.sourceforge.net/.)

Comment 2 Jens Petersen 2005-05-18 07:18:04 UTC
emacs-21.4-5 will contain the updated cc-mode.

Comment 3 Jens Petersen 2005-06-04 08:34:00 UTC
I closing this off based on feedback from bug 148977 and bug 150197.
Thanks.


Note You need to log in before you can comment on or make changes to this bug.