Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158036 - perl: updating CGI.pm to 3.10
Summary: perl: updating CGI.pm to 3.10
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 23:56 UTC by Jose Pedro Oliveira
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 01:08:14 UTC


Attachments (Terms of Use)
CGI.pm update: from version 3.08 to 3.10 (deleted)
2005-05-17 23:56 UTC, Jose Pedro Oliveira
no flags Details | Diff
perl.spec patch: includes the CGI.pm update patch (deleted)
2005-05-18 21:52 UTC, Jose Pedro Oliveira
no flags Details | Diff

Description Jose Pedro Oliveira 2005-05-17 23:56:28 UTC
Description of problem:
The current perl package includes a patch to update CGI.pm to version
3.08 (as required by mod_perl 2.0.0 RC5).  Right now it makes sense to update
CGI.pm to the latest CPAN version (3.10).  These two latest releases correct
mod_perl related problems.

CGI.pm: diff from 3.08 to 3.10
http://search.cpan.org/diff?from=CGI.pm-3.08&to=CGI.pm-3.10

Note:
CGI.pm 3.10 will be included in perl 5.8.7. Perl 5.8 devel branch:
http://public.activestate.com/gsar/APC/perl-5.8.x/lib/CGI.pm

Comment 1 Jose Pedro Oliveira 2005-05-17 23:56:28 UTC
Created attachment 114492 [details]
CGI.pm update: from version 3.08 to 3.10

Comment 2 Warren Togami 2005-05-18 00:02:07 UTC
In order to make the case for upgrading this during this freeze, you must
demonstrate that the current version is horribly broken (exactly how?) and it
makes no sense to backport the fix (the patch is too big or comprises the entire
new upstream version?)

Comment 3 Jose Pedro Oliveira 2005-05-18 00:57:31 UTC
You are not upgrading a full package: we will be adding a new patch to
perl (or replace an existing one).

1) Strange errors have been reported the mod_perl mailling list:

  * Re: It did not QUITE work! Re: "strange error" is related to CGI.pm 
    http://marc.theaimsgroup.com/?l=apache-modperl&m=111601794202239&w=2
    (17 messages)

  * CGI.pm 3.10 is on CPAN
    http://marc.theaimsgroup.com/?l=apache-modperl&m=111602212309524&w=2

2) the diff from 3.08 to 3.10 is small: it only modifies two files
    i) three lines in the CGI module
    ii) a test file

3) the upgrade to mod_perl 2.0.0 RC5 (and later) _will_ break a lot of
   applications: while most CPAN mod_perl related modules have already
   been updated, there is at least one - HTML::Mason - that hasn't and
   won't be until the final version of mod_perl 2.0.0 is out (expected
   soon but we never know: mod_perl 2 has been in beta stage for at
   least three years); other modules will suffer more than one update
   to get things fixed (eg: CGI.pm).


Comment 4 Ville Skyttä 2005-05-18 16:11:40 UTC
Definitely worth applying before FC4, if you ask me.

Re: comment 2: freeze?  I thought the FC4 freeze starts on May 23rd.
https://www.redhat.com/archives/fedora-maintainers/2005-May/msg00096.html

Comment 5 Jose Pedro Oliveira 2005-05-18 21:52:49 UTC
Created attachment 114539 [details]
perl.spec patch: includes the CGI.pm update patch

Comment 6 Warren Togami 2005-05-18 22:13:14 UTC
this is already committed, waiting on rel-eng



Note You need to log in before you can comment on or make changes to this bug.