Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158033 - lvm kickstart install is not growing phyical volume
Summary: lvm kickstart install is not growing phyical volume
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 23:20 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 21:54:18 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2005-05-17 23:20:07 UTC
Description of problem:
With the following partition setup in a kickstart file:

clearpart --linux
part /boot --fstype ext3 --size=50
part pv.1 --size=5800 --grow
volgroup rootvg pv.1
logvol / --vgname=rootvg --size=512 --name=root
logvol swap --fstype=swap --vgname=rootvg --recommended --name=swap
logvol /usr --vgname=rootvg --size=4000 --name=usr
logvol /var --vgname=rootvg --size=256 --name=var
logvol /export/data1 --vgname=rootvg --size=1 --grow --name=data1

I'm trying to install on a 10GB disk, but it is not growing pv.1 to fill the
rest of the disk.  Instead I seem to be getting random sizes.  In fact, as I
increase the --size parameter for pv.1, the partition it creates keeps getting
smaller.  Actually, it appears that it is treating "size" as the amount of disk
space to keep free on the disk.


How reproducible:
everytime

Comment 1 Jeremy Katz 2005-05-19 01:39:55 UTC
Are there any pre-existing non-linux partitions on the disk?

Comment 2 Orion Poplawski 2005-05-19 03:27:45 UTC
It doesn't seem to matter if there are or not.  I've seen it on both of my
fc4test3 installs, one on a linux only disk (1 ext3 boot, 1 LVM) and one with
existing HFS+ partitions (on a mac).

Comment 3 Jeremy Katz 2005-05-19 12:25:10 UTC
On the linux only disk, can you see if clearpart --all makes any difference?

Comment 4 Orion Poplawski 2005-05-19 15:01:05 UTC
clearpart --all does not appear to make any difference.

Comment 5 Chris Lumens 2005-05-23 16:04:43 UTC
Please try out the updates.img available from 
http://people.redhat.com/clumens/158033-update/ and let me know if it makes any
difference.  This is a test fix for a different problem that has some similar
behavior to what you're seeing.

Comment 6 Orion Poplawski 2005-05-23 16:17:50 UTC
Does not appear to have any effect (this is placed in the Fedora/base/ directory
for NFS installs, right?).



Comment 7 Chris Lumens 2005-06-07 20:07:00 UTC
I'm unable to reproduce this on our later FC4 tests.  Please test again with FC4
and let us know if it's still broken.  I've seen similar symptoms regarding
using the size as the amount of free space to leave, and I believe it should be
fixed now.

Comment 8 Orion Poplawski 2005-06-07 20:12:48 UTC
Um, where do I get a later FC4 test?

Comment 9 Orion Poplawski 2005-07-06 21:54:18 UTC
Appears to be fixed in FC4 final


Note You need to log in before you can comment on or make changes to this bug.