Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1580285 - QoS burst - wrong units displayed in engine webadmin and engine-config and wrong values passed to libvirt
Summary: QoS burst - wrong units displayed in engine webadmin and engine-config and w...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.2
Hardware: All
OS: All
low
medium vote
Target Milestone: ovirt-4.2.5
: ---
Assignee: eraviv
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-21 07:27 UTC by eraviv
Modified: 2018-07-31 15:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 15:25:22 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
mburman: testing_plan_complete+
mburman: testing_ack+


Attachments (Terms of Use)
webadmin network QoS form (deleted)
2018-05-21 07:27 UTC, eraviv
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 91247 master MERGED engine: QoS burst - align with libvirt 2018-06-04 07:08:22 UTC
oVirt gerrit 91425 model_4.2 MERGED api-model: QoS burst - align unit of measure 2018-06-04 12:25:01 UTC
oVirt gerrit 91922 model_4.2 MERGED api-model: QoS burst - align unit of measure 2018-06-04 12:25:17 UTC
oVirt gerrit 92054 ovirt-engine-4.2 MERGED engine: QoS burst - align with libvirt 2018-06-11 14:05:12 UTC
oVirt gerrit 92132 master MERGED core: QoS burst - fix conversion factor 2018-06-13 12:37:58 UTC
oVirt gerrit 92244 ovirt-engine-4.2 MERGED core: QoS burst - fix conversion factor 2018-06-17 08:37:19 UTC

Description eraviv 2018-05-21 07:27:41 UTC
Created attachment 1439423 [details]
webadmin network QoS form

Description of problem:
QoS burst units of measure are displayed incorrectly and inconsistently in the webadmin form and in the engine-config output

Version-Release number of selected component (if applicable):
4.2

How reproducible:
100%

Steps to Reproduce:
1. run engine-cofing -l | grep QoS --> max burst units are Mb, inbound\outbound burst units are Mbps
2. webadmin > compute > datacenter > network QoS > MB/s

Actual results:
wrong and inconsistent units are reported\displayed

Expected results:
displayed units for all burst values should be MiB as is reported by the REST API documentation.

Additional info:
Burst units are not mentioned in https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/html-single/administration_guide/

Comment 2 Michael Burman 2018-07-03 12:21:37 UTC
Verified on - 4.2.5-0.1.el7ev

Comment 3 Sandro Bonazzola 2018-07-31 15:25:22 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.