Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158026 - Massive failure to boot FC on Blue-and-White G3
Summary: Massive failure to boot FC on Blue-and-White G3
Keywords:
Status: CLOSED DUPLICATE of bug 162046
Alias: None
Product: Fedora
Classification: Fedora
Component: yaboot
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
: 157771 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 20:56 UTC by Ignacio Vazquez-Abrams
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-24 21:32:58 UTC


Attachments (Terms of Use)
/dev/hda9:/ofboot.b (deleted)
2005-05-17 21:52 UTC, Ignacio Vazquez-Abrams
no flags Details

Description Ignacio Vazquez-Abrams 2005-05-17 20:56:52 UTC
The yaboot stage 1 menu shows up, but choosing either "L" or "X" results in the
system either randomly restarting yaboot stage 1, showing the blinking question
mark/face folder for a minute then gong back to stage 1, or booting OS X
(regardless of which option was chosen). The machine is a very old
Blue-and-White G3 that had its firmware updated to 1.1.0.

** Partition table:
Disk geometry for /dev/hda: 0.000-58644.140 megabytes
Disk label type: mac
Minor    Start       End     Filesystem  Name                  Flags
1          0.000      0.031              Apple                 
2          0.031      0.058              Macintosh             
3          0.059      0.085              Macintosh             
4          0.086      0.113              Macintosh             
5          0.113      0.140              Macintosh             
6          0.141      0.390              Macintosh             
7          0.391      0.640              Macintosh             
8          0.641      0.890              Patch Partition       
9          0.891      1.890  hfs         untitled              boot
10       128.891  12288.890  hfs+        Apple_HFS_Untitled_4  
11     12288.891  27288.890  ext3        untitled              
12     27288.891  29336.890  linux-swap  swap                  swap
13     29336.891  58643.140  ext3        untitled              

                                                                          
Information: Don't forget to update /etc/fstab, if necessary.


** anaconda-ks.cfg:
# Kickstart file automatically generated by anaconda.

install
nfs --server=ignacio --dir=/nfs/FC4t3ppc
lang en_US.UTF-8
langsupport --default=en_US.UTF-8
keyboard us
xconfig --card "ATI Rage 128" --videoram 1048576 --hsync 31.5-37.9 --vsync 50-70
--resolution 800x600 --depth 16 --startxonboot  --defaultdesktop gnome
network --device eth0 --bootproto static --ip 192.168.0.12 --netmask
255.255.255.0 --gateway 192.168.0.1 --nameserver 192.168.0.1 --hostname
g3.ignacio.lan
rootpw --iscrypted xxxxxxxxxxxxxxxxxxx
firewall --enabled --port=22:tcp
selinux --enforcing
authconfig --enableshadow --enablemd5
timezone --utc America/Toronto
bootloader --location=partition --driveorder=hda --append="rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --linux
#part appleboot --fstype "Apple Bootstrap" --noformat --onpart hda9
#part / --fstype ext3 --onpart hda11
#part /home --fstype ext3 --onpart hda13
#part swap --noformat --onpart hda12

%packages
@ gnome-desktop
@ dialup
@ java
@ base-x
kernel
kernel-devel
yaboot
e2fsprogs

%post


** install.log.syslog:
<86>May 17 09:46:06 useradd[655]: new group: name=dbus, gid=81

<86>May 17 09:46:06 useradd[655]: new user: name=dbus, uid=81, gid=81, home=/,
shell=/sbin/nologin
<86>May 17 09:46:26 groupadd[695]: new group: name=floppy, gid=19
<86>May 17 09:46:27 useradd[696]: new group: name=vcsa, gid=69

<86>May 17 09:46:27 useradd[696]: new user: name=vcsa, uid=69, gid=69,
home=/dev, shell=/sbin/nologin
<86>May 17 09:47:01 groupadd[715]: new group: name=rpm, gid=37
<86>May 17 09:47:01 useradd[716]: new user: name=rpm, uid=37, gid=37,
home=/var/lib/rpm, shell=/sbin/nologin
<86>May 17 09:47:09 groupadd[741]: new group: name=utmp, gid=22
<86>May 17 09:47:49 useradd[940]: new group: name=haldaemon, gid=68

<86>May 17 09:47:49 useradd[940]: new user: name=haldaemon, uid=68, gid=68,
home=/, shell=/sbin/nologin
<86>May 17 09:48:55 groupadd[992]: new group: name=slocate, gid=21
<86>May 17 09:48:56 groupadd[995]: new group: name=pcap, gid=77
<86>May 17 09:48:56 useradd[996]: new user: name=pcap, uid=77, gid=77,
home=/var/arpwatch, shell=/sbin/nologin
<86>May 17 09:49:20 useradd[1032]: new group: name=nscd, gid=28

<86>May 17 09:49:20 useradd[1032]: new user: name=nscd, uid=28, gid=28, home=/,
shell=/sbin/nologin
<86>May 17 09:49:46 groupadd[1083]: new group: name=named, gid=25
<86>May 17 09:49:46 useradd[1084]: new user: name=named, uid=25, gid=25,
home=/var/named, shell=/sbin/nologin
<86>May 17 09:50:20 useradd[1141]: new group: name=sshd, gid=74

<86>May 17 09:50:20 useradd[1141]: new user: name=sshd, uid=74, gid=74,
home=/var/empty/sshd, shell=/sbin/nologin
<86>May 17 09:50:22 groupadd[1148]: new group: name=rpc, gid=32
<86>May 17 09:50:22 useradd[1149]: new user: name=rpc, uid=32, gid=32, home=/,
shell=/sbin/nologin
<86>May 17 09:50:22 useradd[1151]: new group: name=rpcuser, gid=29

<86>May 17 09:50:22 useradd[1151]: new user: name=rpcuser, uid=29, gid=29,
home=/var/lib/nfs, shell=/sbin/nologin
<86>May 17 09:50:23 useradd[1155]: new group: name=nfsnobody, gid=-2

<86>May 17 09:50:23 useradd[1155]: new user: name=nfsnobody, uid=4294967294,
gid=4294967294, home=/var/lib/nfs, shell=/sbin/nologin
<86>May 17 09:50:26 useradd[1163]: new group: name=mailnull, gid=47

<86>May 17 09:50:26 useradd[1163]: new user: name=mailnull, uid=47, gid=47,
home=/var/spool/mqueue, shell=/sbin/nologin
<86>May 17 09:50:27 useradd[1164]: new group: name=smmsp, gid=51

<86>May 17 09:50:27 useradd[1164]: new user: name=smmsp, uid=51, gid=51,
home=/var/spool/mqueue, shell=/sbin/nologin
<21>May 17 09:50:29 sendmail[1174]: alias database /etc/aliases rebuilt by root
<22>May 17 09:50:29 sendmail[1174]: /etc/aliases: 76 aliases, longest 10 bytes,
765 bytes total
<86>May 17 09:52:51 useradd[1626]: new group: name=xfs, gid=43

<86>May 17 09:52:51 useradd[1626]: new user: name=xfs, uid=43, gid=43,
home=/etc/X11/fs, shell=/sbin/nologin
<86>May 17 09:54:01 groupadd[1690]: new group: name=ntp, gid=38
<86>May 17 09:54:03 useradd[1691]: new user: name=ntp, uid=38, gid=38,
home=/etc/ntp, shell=/sbin/nologin
<14>May 17 09:56:28 gconfd (root-1924): starting (version 2.10.0), pid 1924 user
'root'
<14>May 17 09:56:28 gconfd (root-1924): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
<14>May 17 09:56:28 gconfd (root-1924): Resolved address
"xml:readwrite:/root/.gconf" to a writable configuration source at position 1
<14>May 17 09:56:28 gconfd (root-1924): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
<14>May 17 09:56:32 gconfd (root-1924): Exiting
<86>May 17 09:58:39 useradd[2242]: new group: name=gdm, gid=42

<86>May 17 09:58:39 useradd[2242]: new user: name=gdm, uid=42, gid=42,
home=/var/gdm, shell=/sbin/nologin
<86>May 17 09:58:40 usermod[2243]: change user `gdm' shell from `/sbin/nologin'
to `/sbin/nologin'
<13>May 17 10:07:23 kudzu: ran mouseconfig for input/mice
<13>May 17 10:07:24 kudzu: ran mouseconfig for input/mice
<13>May 17 10:07:24 kudzu: aliased snd-card-0 as snd-powermac
<87>May 17 10:07:25 userhelper[8049]: pam_timestamp: updated timestamp file
`/var/run/sudo/root/tty1'
<85>May 17 10:07:25 userhelper[8050]: running
'/usr/share/system-config-display/system-config-display --reconfig --noui
--set-card=ATI Rage 128 --set-videoram=1048576' with root privileges on behalf
of 'root'
<13>May 17 10:07:29 kudzu: ran system-config-display for Card:ATI Rage 128
<13>May 17 10:07:29 kudzu: aliased usb-controller as ohci-hcd
<13>May 17 10:07:29 kudzu: aliased usb-controller1 as ehci-hcd
<13>May 17 10:07:29 kudzu: aliased usb-controller2 as uhci-hcd
<13>May 17 10:07:29 kudzu: aliased ieee1394-controller as pcilynx

Comment 1 Paul Nasrat 2005-05-17 21:03:45 UTC
Can you attach the ofboot.b from /dev/hda9 (chroot /mnt/sysimage then mount).

Can you also let me know the boot-device and open firmware version from OF

Cmd+Option OF 

the of version is in the banner
printenv boot-device

I expect hd:,9:\\tbxi

Can you try booting with hd:9,\yaboot

Comment 2 Ignacio Vazquez-Abrams 2005-05-17 21:52:47 UTC
Created attachment 114484 [details]
/dev/hda9:/ofboot.b

Apple PowerMac1,1 1.1f4 BootROM built on 04/09/99 at 13:57:32
OpenFirmware 3.1.1

boot-device=hd:,\\:txbi

"boot hd:9,\yaboot" successfully brought up stage 2, which allowed me to boot
into Fedora.

Comment 3 Paul Nasrat 2005-05-17 22:22:58 UTC
It may be that your OF version really doesn't like the chrp script that yaboot
stage1 uses.  Without access to identical version it's hard for me to say
precisely.  I can probably write a simpler version of the script for testing
that hypothesis out.  However that is likely to take a little bit of time.

Comment 4 Paul Nasrat 2005-05-18 14:01:56 UTC
Dropping severity as work around (manual yaboot available).

Comment 5 Paul Nasrat 2005-05-18 14:23:35 UTC
*** Bug 157771 has been marked as a duplicate of this bug. ***

Comment 6 Paul Nasrat 2005-05-18 14:36:43 UTC
Do either of the people seeing issues here have a scsi card in their system?

Comment 7 Ignacio Vazquez-Abrams 2005-05-18 14:52:34 UTC
Don't think so...

00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
00:0d.0 PCI bridge: Digital Equipment Corporation DECchip 21154 (rev 02)
00:10.0 VGA compatible controller: ATI Technologies Inc Rage 128 RE/SG
01:00.0 FireWire (IEEE 1394): Texas Instruments PCILynx/PCILynx2 IEEE 1394 Link
Layer Controller (rev 02)
01:01.0 IDE interface: Silicon Image, Inc. PCI0646 (rev 05)
01:03.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 50)
01:03.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 50)
01:03.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
01:05.0 Class ff00: Apple Computer Inc. Paddington Mac I/O
01:06.0 USB Controller: OPTi Inc. 82C861 (rev 10)

Comment 8 Colin Charles 2005-07-22 13:25:30 UTC
Does FC-4 run on this, or does the workaround in comment #2 still apply ?

Comment 9 Paul Nasrat 2005-07-22 14:22:36 UTC
FC 4 will run, the issue is whether OF on B&W supports the ofboot.b scripts we
use.  Without the hardware it's pretty impossible for me to tell.

Comment 10 Ignacio Vazquez-Abrams 2005-07-22 20:38:26 UTC
The workaround is still required.

I'm certainly willing to run any tests wrt ofboot.b that you deem fit.

Comment 11 Paul Nasrat 2006-01-24 21:32:58 UTC
Closing as dupe of bug with more debugging.

*** This bug has been marked as a duplicate of 162046 ***


Note You need to log in before you can comment on or make changes to this bug.