Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158015 - [PATCH] i915 DRI driver lacks support for i945G integrated graphics
Summary: [PATCH] i915 DRI driver lacks support for i945G integrated graphics
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 20:27 UTC by wingc
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-17 21:52:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
[PATCH] support i945G as i915G in DRI driver, xorg-x11-6.8.2 (deleted)
2005-05-17 20:27 UTC, wingc
no flags Details | Diff

Description wingc 2005-05-17 20:27:01 UTC
Description of problem:

The i915 DRI OpenGL driver, included in xorg-x11-6.8.2, does not support the
i945G integrated graphics controller found in recent Intel-based x86_64 capable
PCs. It seems to work properly with the i945G if the appropriate PCI IDs are added.

Version-Release number of selected component (if applicable):

Tested most recent RHEL4 beta xorg-x11 RPM (xorg-x11-6.8.2-1.EL.5)

How reproducible:

Always

Steps to Reproduce:
1. try to set up DRI for OpenGL acceleration on a machine with i945G integrated
graphics
  
Actual results:

i915_dri.so does not recognize the i945G graphics controller

Expected results:


Additional info:


Here is a patch against the xorg-x11-6.8.2 sources from RHEL4 (most recent beta,
xorg-x11-6.8.2-1.EL.5) that adds the necessary code to drive the i945G as a i915G.

With the attached patch I rebuilt the i915_dri.so driver from the most recent
RHEL4 beta, and OpenGL acceleration is working fine on a x86_64 machine. 
(pre-production Dell GX620, x86_64, i945G integrated graphics)

Comment 1 wingc 2005-05-17 20:27:01 UTC
Created attachment 114481 [details]
[PATCH] support i945G as i915G in DRI driver, xorg-x11-6.8.2

Comment 2 wingc 2005-05-17 20:46:39 UTC
See also the related bugs:
                                                                                
bug #157991 (intel-agp driver needed on x86_64)
bug #157995 (support i945G host bridge in intel-agp driver)
bug #157997 (i915 DRM kernel module needed on x86_64)
bug #158000 (support i945G integrated graphics in i915 DRM kernel module)
bug #158014 (support i945G integrated graphics in xorg-x11 i810 driver)
bug #158016 (disable debugging output to stderr in i915 DRI driver, x86_64)
                                                                                
Taken as a series, when these are all resolved it will be possible to get
working OpenGL acceleration in RHEL4 for the i945G integrated graphics chipset
on x86_64.

Comment 3 Mike A. Harris 2005-05-17 21:52:39 UTC

*** This bug has been marked as a duplicate of 156964 ***


Note You need to log in before you can comment on or make changes to this bug.