Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157980 - RFE: Upgrade gramps to 2.0 version
Summary: RFE: Upgrade gramps to 2.0 version
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gramps
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phillip Compton
QA Contact: Fedora Extras Quality Assurance
URL: http://www.gramps-project.org/index.p...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 15:32 UTC by Zuirdj
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-01 23:23:58 UTC


Attachments (Terms of Use)

Description Zuirdj 2005-05-17 15:32:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
Announcement of the new version (stable release) on May 11, 2005

Changes from the 1.0.x series include:

    * Berkeley database backend
    * Changes are written to disk immediately
    * Removal of alphabetical tabs
    * Ability to add/remove/rearrange columns in list views
    * Removal of Save function and addition of Undo
    * Proper window management and removal of most modal windows
    * Support for Tip of the Day
    * Person-dependent context menus (right-click) in Pedigree View listing parents, children, spouses, and siblings
    * Export wizard
    * Built-in Find function in list views
    * Date selector dialog
    * Name editor enhancements: patronymic names and non-default grouping
    * Recent file support (both gramps-specific and gnome-wide)
    * Other database backends
    * Native editing (in memory) for GRAMPS XML and GEDCOM formats
    * New import and export filters available for the GeneWeb format.
    * New report (Statistics Chart) added
    * Persistent options for reports
    * The new command line functionality (opening and report generation)
    * Better date internationalization (date parsers available for French, Russian, and Spanish, with Finnish in the works).
    * Better name internationalization (patronymics and non-default grouping).
    * Mime types for formats known to GRAMPS.
    * Schemas and proper structure for GConf keys, immediate preference effect.

http://www.gramps-project.org/index.php?module=announce&ANN_user_op=view&ANN_id=9 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. # yum list gramps -> gramps.i386   1.0.10-2
2. Visit http://www.gramps-project.org/ to see the new release (2.0)
3.
  

Additional info:

Comment 1 Brian Pepple 2005-05-22 22:05:49 UTC
Package updated, and should be pushed into the development branch once it's signed.

http://extras64.linux.duke.edu/needsign/development/gramps/2.0.0-1/

Comment 2 Zuirdj 2005-06-01 21:32:17 UTC
You can close this bug, now Extras devel has gramps-2.0.0-1.


Comment 3 Michael Schwendt 2005-06-01 22:36:59 UTC
This ticket confuses me. Who "owns" the gramps package?


Comment 4 Brian Pepple 2005-06-01 23:04:47 UTC
Phillip still owns the package, but since he is short on time currently, he said
it was ok for me to upgrade the package.

Comment 5 Michael Schwendt 2005-06-01 23:23:58 UTC
Okay. Thanks for the quick reply.



Note You need to log in before you can comment on or make changes to this bug.