Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157966 - Crash when going to end of page (fedora rpm only)
Summary: Crash when going to end of page (fedora rpm only)
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL: http://www.believermag.com/issues/200...
Whiteboard: FF3RawhideClose
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 14:34 UTC by Robin Green
Modified: 2018-04-11 14:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-20 16:46:44 UTC


Attachments (Terms of Use)
Log taken with script -c 'firefox http://www.believermag.com/issues/200504/interview_mieville.php' crash.log (deleted)
2005-05-17 14:34 UTC, Robin Green
no flags Details
Backtrace taken with gdb (deleted)
2005-05-20 10:27 UTC, Robin Green
no flags Details

Description Robin Green 2005-05-17 14:34:51 UTC
Description of problem:
This error does *not* occur with firefox 1.0.4 from mozilla.org. It only occurs
with the Fedora firefox RPM.

Firefox hangs with this error on the console when the instructions below are
followed: "*** glibc detected *** /usr/lib/firefox-1.0.4/firefox-bin: double
free or corruption (!prev): 0x0910e3f0 ***

Version-Release number of selected component (if applicable):
firefox-1.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. Go to http://www.believermag.com/issues/200504/interview_mieville.php
2. press the END key
  
Actual results:
See attached log file

Expected results:
No crash

Additional info:
glibc-2.3.5-6
libstdc++-4.0.0-5

Comment 1 Robin Green 2005-05-17 14:34:51 UTC
Created attachment 114462 [details]
Log taken with script -c 'firefox http://www.believermag.com/issues/200504/interview_mieville.php' crash.log

Comment 2 Warren Togami 2005-05-17 21:42:52 UTC
We need you to install the firefox-debuginfo package and use gdb to get a traceback.

Comment 3 Warren Togami 2005-05-17 21:55:47 UTC
Unable to reproduce this problem on x86_64 FC4.

Comment 4 Robin Green 2005-05-20 10:27:00 UTC
Created attachment 114619 [details]
Backtrace taken with gdb

Comment 5 Robin Green 2005-05-20 10:28:07 UTC
OK, here it is.

Comment 6 Dennis Wagelaar 2006-05-02 09:45:59 UTC
I get the same behaviour when going to www.parijs.nl/id/844/Metro.html and try
to scroll down or press End. I'm using firefox-1.5.0.2-1.2.fc5. I have not tried
any firefox package from mozilla.org.

Comment 7 Matěj Cepl 2007-12-20 16:46:44 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.