Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157965 - System hang when starting X
Summary: System hang when starting X
Keywords:
Status: CLOSED DUPLICATE of bug 157859
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 14:34 UTC by theseventhsage
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-26 08:03:01 UTC


Attachments (Terms of Use)

Description theseventhsage 2005-05-17 14:34:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
On a Powerbook G4 (PowerBook5,6 as identified in /proc/cpuinfo) with a Radeon 9600 video chipset, starting X hangs the system immediately.  I have tried various configuration changes in /etc/X11/xorg.conf, including Option "UseFBDev" and Option "NoAccel", with no success.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-31

How reproducible:
Always

Steps to Reproduce:
Boot into runlevel 5 or run startx.


Actual Results:  The screen goes black, as it would just before loading a window manager or desktop environment, but nothing further happens and the system no longer responds to anything except the power button (it won't even respond to a ping).

Expected Results:  GNOME should have started and the system should have been responsive to the keyboard and to a ping.

Additional info:

Comment 1 Frank Arnold 2005-05-19 10:02:49 UTC
Same problem here.

I tried the xorg packages from 3.91 (xorg-x11-6.8.2-19) and got it to work.

My manually edited xorg.conf is similar to this one (except "Files" and touchpad
sections):
https://www.redhat.com/archives/fedora-test-list/2005-March/msg00429.html

Unfortunatly the touchpad don't work because the synaptics driver is missing
(package only available for other architectures).

Comment 2 Mike A. Harris 2005-05-24 16:01:00 UTC
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO", awaiting X.Org bug URL for tracking.

Comment 3 Frank Arnold 2005-05-24 20:25:31 UTC
Forgot to mention that the installation was only possible in text mode.
Therefore this bug seems to be a duplicate of #157859

Related xorg bug: https://bugs.freedesktop.org/show_bug.cgi?id=3318

(Track pad is not xorg related. See http://seehuhn.de/comp/powerbook/index )

Comment 4 theseventhsage 2005-05-25 05:10:35 UTC
This bug is in fact a duplicate of #157859, and the X.org bug referenced above
is an accurate representation of my issue.

Comment 5 Mike A. Harris 2005-05-26 08:03:01 UTC

*** This bug has been marked as a duplicate of 157859 ***


Note You need to log in before you can comment on or make changes to this bug.