Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157944 - modprobe sbp2 not using options from modprobe.conf on boot
Summary: modprobe sbp2 not using options from modprobe.conf on boot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 11:40 UTC by Garnet Ulrich
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 17:48:01 UTC


Attachments (Terms of Use)
dmesg to see how early sbp2 is being loaded (deleted)
2005-05-17 15:37 UTC, Garnet Ulrich
no flags Details
modprobe.conf (deleted)
2005-05-17 15:37 UTC, Garnet Ulrich
no flags Details

Description Garnet Ulrich 2005-05-17 11:40:23 UTC
Description of problem:
During boot sbp2 is loaded to support an external hard drive. 
/etc/modprobe.conf starts with the following line
options sbp2 serialize_io=1
sbp2 is not being started with this option.  Bottom line,
/etc/modprobe.conf option is being ignored in startup scripts.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1.  Put "options sbp2 serialize_io=1 in /etc/modprobe.conf
2.  Boot system with firewire hard drive.
3.  Check syslog and find that option was not used with modprobe.
  
Actual results:
Syslog shows:
sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>


Expected results:
Syslog should show:
sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>
kernel: ieee1394: sbp2: Driver forced to serialize I/O (serialize_io = 1)

Additional info:
The only way I've found to get sbp2 to be set with serialize_io=1 is to 
recompile the module with the default value of serialize_io set to 1.  The
scripts seem to be broken.

Comment 1 Garnet Ulrich 2005-05-17 11:49:49 UTC
OK, I see now (only minutes after opening this bug) that this has nothing to do
with scripts and in fact modprobe is not behaving correctly.  According to the
man page for modprobe, the options in modprobe.conf should always get used. 
This is not happening.



Comment 2 Bill Nottingham 2005-05-17 14:26:11 UTC
I can't reproduce this in brief testing on FC4 test; adding:

options sbp2 serialize_io=1

to /etc/modprobe.conf

and running:

modprobe sbp2

by hand causes the right thing to happen.

Can you tell where it's getting loaded?

Comment 3 Garnet Ulrich 2005-05-17 15:36:24 UTC
I get the same results as you with a manual modprobe.  I removed the firewire
card from my system so it wasn't loaded at boot.  After reboot I manually
modprobe sbp2 and yes, serialize_io=1 is used from the modprobe.conf.

If modprobe is called during the boot process, serialize_io=1 is not done.

Attached is my dmesg so you can see where in my boot sbp2 is being loaded.  Also
attached is my modprobe.conf.

Comment 4 Garnet Ulrich 2005-05-17 15:37:14 UTC
Created attachment 114466 [details]
dmesg to see how early sbp2 is being loaded

Comment 5 Garnet Ulrich 2005-05-17 15:37:58 UTC
Created attachment 114467 [details]
modprobe.conf

Comment 6 Bill Nottingham 2005-05-17 19:55:56 UTC
Looks like it's getting loaded in your initrd. Did you remake it after adding
the option to modprobe.conf?


Comment 7 Garnet Ulrich 2005-05-19 17:48:01 UTC
No.  Sorry for wasting your time.  


Note You need to log in before you can comment on or make changes to this bug.