Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157924 - galeon 1.3.20-2.fc3 for mozilla 1.7.7 blocks 1.7.8 update
Summary: galeon 1.3.20-2.fc3 for mozilla 1.7.7 blocks 1.7.8 update
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 05:48 UTC by Alex Lancaster
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.3.21-2.fc3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-28 09:47:35 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2005-05-17 05:48:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Galeon/1.3.20

Description of problem:
galeon 1.3.20-2.fc3 is built for mozilla-1.7.7 and it blocks the update to mozilla-1.7.8.  galeon needs to be rebuilt against the updated mozilla.

Version-Release number of selected component (if applicable):
galeon-1.3.20-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. Attempt to upgrade via apt-get.
2. run "apt-get upgrade"

  

Actual Results:  $ sudo apt-get upgrade
Password:
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages have been kept back
   epiphany (1.4.4-4.3.2 => 1.4.4-4.3.3)
   mozilla (1.7.7-1.3.1 => 1.7.8-1.3.1)
   mozilla-devel (1.7.7-1.3.1 => 1.7.8-1.3.1)
   mozilla-dom-inspector (1.7.7-1.3.1 => 1.7.8-1.3.1)
   mozilla-mail (1.7.7-1.3.1 => 1.7.8-1.3.1)
   mozilla-nspr (1.7.7-1.3.1 => 1.7.8-1.3.1)
   mozilla-nspr-devel (1.7.7-1.3.1 => 1.7.8-1.3.1)
   mozilla-nss (1.7.7-1.3.1 => 1.7.8-1.3.1)
   mozilla-nss-devel (1.7.7-1.3.1 => 1.7.8-1.3.1)
0 upgraded, 0 newly installed, 0 removed and 9 not upgraded.



Expected Results:  Mozilla update should have worked and both mozilla and galeon should have been upgraded.  The update fails because of this:

$ rpm -q --requires galeon
<snip>
mozilla = 37:1.7.7
<snip>

Additional info:

Comment 1 Dams 2005-05-17 11:46:06 UTC
Will schedule a rebuild

Comment 2 Dams 2005-05-23 15:05:12 UTC
galeon 1.3.21 will be rebuilt for FC3 shortly.

Comment 3 Andrew D. 2005-05-24 03:58:11 UTC
Hi, This isn't exactly the same problem but on Enterprise 4 AS, using RedHat
Network, upgrading is not allowed giving a warning that devhelp-0.9.2-2.4.4
requires Mozilla 1.7.7. There is no update for devhelp for Ent 4. 
Thanks,
Andrew

Comment 4 Andrew D. 2005-05-24 16:32:43 UTC
Just saw the new update for devhelp. Fixed the problem. Thanks!

Comment 5 Alex Lancaster 2005-05-27 10:19:24 UTC
Haven't seen a new rebuild for FC3 yet, just wondering if there was any build
problems or otherwise holding it up.  How does one request a new build?

Comment 6 Dams 2005-05-27 12:08:30 UTC
I've asked the rebuild last week but it failed due to some missing cvs tag. Now
the directory has been tagged and I've re-asked for rebuild last monday or so.
I'll ask for more information.

Comment 7 Michael Schwendt 2005-05-27 13:04:13 UTC
I believe the build system ignores requests for tags seen before. To save some
time, I've bumped and requested a build of galeon-1_3_21-2_fc3.

Comment 8 Michael Schwendt 2005-05-27 18:02:34 UTC
Build succeeded. Should appear in the repository as soon as a release manager
signs the packages.


Comment 9 Alex Lancaster 2005-05-28 09:47:35 UTC
Succesfully installed galeon-1.3.21-2.fc3 and mozilla-1.7.8 updates via apt.  
Runs fine.  Closing bug.


Note You need to log in before you can comment on or make changes to this bug.